aboutsummaryrefslogtreecommitdiffstats
path: root/games/enigma
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2006-09-15 16:17:11 +0800
committerlinimon <linimon@FreeBSD.org>2006-09-15 16:17:11 +0800
commitf2d8437c35c46dc1131c982c1f25abcd7d641fb3 (patch)
tree61136cc420c647223541df746f011f5307a7b184 /games/enigma
parent6c16383d95de00351d4ecaf674a95f310d209a6b (diff)
downloadfreebsd-ports-gnome-f2d8437c35c46dc1131c982c1f25abcd7d641fb3.tar.gz
freebsd-ports-gnome-f2d8437c35c46dc1131c982c1f25abcd7d641fb3.tar.zst
freebsd-ports-gnome-f2d8437c35c46dc1131c982c1f25abcd7d641fb3.zip
Modify these files to reflect bsd.lua.mk as tested on the cluster.
PR: ports/101612 Submitted by: alepulver Hat: portmgr
Diffstat (limited to 'games/enigma')
-rw-r--r--games/enigma/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/games/enigma/Makefile b/games/enigma/Makefile
index 5e35d45dc76d..8c33648d3237 100644
--- a/games/enigma/Makefile
+++ b/games/enigma/Makefile
@@ -15,21 +15,23 @@ DISTNAME= enigma-${PORTVERSION}
MAINTAINER= anholt@FreeBSD.org
COMMENT= Enigma is a reimplementation of Oxyd, a puzzle game
-BUILD_DEPENDS= ${LOCALBASE}/bin/tolua:${PORTSDIR}/lang/tolua4
-LIB_DEPENDS= zipios.0:${PORTSDIR}/archivers/zipios++ \
- lua.4:${PORTSDIR}/lang/lua4
+LIB_DEPENDS= zipios.0:${PORTSDIR}/archivers/zipios++
USE_GCC= 3.4
-
-GNU_CONFIGURE= yes
-USE_XLIB= yes
USE_GMAKE= yes
USE_GETTEXT= yes
+USE_LUA= 4.0
+LUA_COMPS= lua tolua
USE_SDL= gfx image mixer sdl ttf
+USE_XLIB= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target="" \
--with-libintl-prefix="${LOCALBASE}"
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- CXXFLAGS="${PTHREAD_CFLAGS} -I${X11BASE}/include"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+CPPFLAGS= -I${LOCALBASE}/include -I${LUA_INCDIR}
+CXXFLAGS= -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -L${LUA_LIBDIR} ${PTHREAD_LIBS}
MAN6= enigma.6