aboutsummaryrefslogtreecommitdiffstats
path: root/games/evq3
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-12-26 07:29:34 +0800
committerantoine <antoine@FreeBSD.org>2013-12-26 07:29:34 +0800
commitfc17e550eddef887d6e1b70a8e7fc9f06056b731 (patch)
tree5d26acd476642c3b773f75db8040205ff9dc4d29 /games/evq3
parent4c3b90b6bb5bdc235ec60ac72877f1ee418fe1cd (diff)
downloadfreebsd-ports-gnome-fc17e550eddef887d6e1b70a8e7fc9f06056b731.tar.gz
freebsd-ports-gnome-fc17e550eddef887d6e1b70a8e7fc9f06056b731.tar.zst
freebsd-ports-gnome-fc17e550eddef887d6e1b70a8e7fc9f06056b731.zip
Convert the tree to USES=openal
Approved by: portmgr (bapt)
Diffstat (limited to 'games/evq3')
-rw-r--r--games/evq3/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/games/evq3/Makefile b/games/evq3/Makefile
index e20d22192636..381041d34a36 100644
--- a/games/evq3/Makefile
+++ b/games/evq3/Makefile
@@ -35,6 +35,9 @@ OPENAL_DLOPEN_DESC= Enable dynamic loading of OpenAL
SMP_DESC= Build SMP (threaded) client
VOIP_DESC= Enable Voice Over IP
+# USES must be before bsd.port.pre.mk
+OPENAL_USES= openal:al
+
MAKE_ENV= DEFAULT_BASEDIR="${Q3DIR}" LIBDIR="${LIBDIR}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}"
@@ -67,7 +70,6 @@ MAKE_ENV+= USE_CURL_DLOPEN=1
. endif
# OpenAL
. if ${PORT_OPTIONS:MOPENAL}
-USE_OPENAL= al
MAKE_ENV+= USE_OPENAL=1
. if ${PORT_OPTIONS:MOPENAL_DLOPEN}
MAKE_ENV+= USE_OPENAL_DLOPEN=1