aboutsummaryrefslogtreecommitdiffstats
path: root/games/fairymax/Makefile
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2011-05-05 04:18:47 +0800
committerjohans <johans@FreeBSD.org>2011-05-05 04:18:47 +0800
commit1103d623aac56216b9f85a9655edc55333a4c355 (patch)
tree05fb2ee13cfd68a48b3cb468aa78edfe41e9a8dc /games/fairymax/Makefile
parent261847cf0a22ecee98bee3e6e5e85de122a60a36 (diff)
downloadfreebsd-ports-gnome-1103d623aac56216b9f85a9655edc55333a4c355.tar.gz
freebsd-ports-gnome-1103d623aac56216b9f85a9655edc55333a4c355.tar.zst
freebsd-ports-gnome-1103d623aac56216b9f85a9655edc55333a4c355.zip
New port games/fairymax
fairy-Max is a version of micro-Max that reads the piece description from a file fmax.ini, so that arbitrary fairy pieces can be implemen- ted. This version supports up to 15 piece types, and board sizes upto 12x8 board. A Linux port exists in the format of a debian package. You can use it e.g. with games/xboard/: e.g.: xboard -boardSize Middling -variant courier -fcp fairymax GIT: http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=fairymax.git WWW: http://home.hccnet.nl/h.g.muller/fairy.html PR: ports/156535 Submitted by: Kalten <kalten@gmx.at>
Diffstat (limited to 'games/fairymax/Makefile')
-rw-r--r--games/fairymax/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/games/fairymax/Makefile b/games/fairymax/Makefile
new file mode 100644
index 000000000000..6df03ee3cf9e
--- /dev/null
+++ b/games/fairymax/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: fairy-max
+# Date created: 22 April 2011
+# Whom: Kalten <kalten@gmx.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fairymax
+PORTVERSION= 4.8Q
+CATEGORIES= games
+MASTER_SITES= http://freeheimdall.homeunix.org/files/
+DISTNAME= ${PORTNAME}-c7a129e
+# http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=fairymax.git;a=snapshot;h=c7a129ead81286990efb8409f238c48c7109c83b;sf=tgz
+
+MAINTAINER= kalten@gmx.at
+COMMENT= Chess engine (e.g. xboard) for shatranj, courier chess, ...
+
+DIST_SUBDIR= ${PORTNAME}
+
+PLIST_FILES= bin/fairymax \
+ bin/shamax \
+ bin/maxqi \
+ ${DATADIR_REL}/fmax.ini \
+ ${DATADIR_REL}/qmax.ini
+PLIST_DIRS= ${DATADIR_REL}
+
+MAN6= fairymax.6
+MLINKS= fairymax.6 shamax.6 \
+ fairymax.6 maxqi.6
+
+USE_GMAKE= yes
+USE_PERL5_BUILD=yes
+MAKE_ARGS+= INI_FILE_fmax=${DATADIR}/fmax.ini \
+ INI_FILE_qmax=${DATADIR}/qmax.ini
+
+post-patch:
+ @${CP} ${WRKSRC}/fairymax.pod ${WRKSRC}/fairymax.pod.ori
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g;s|%%DATADIR%%|${DATADIR}|g' \
+ ${WRKSRC}/fairymax.pod.ori > ${WRKSRC}/fairymax.pod
+
+post-build:
+ @${CP} ${WRKSRC}/fmax.man ${WRKSRC}/fairymax.6
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/fairymax ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/shamax ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/maxqi ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/data/fmax.ini ${DATADIR}/fmax.ini
+ ${INSTALL_DATA} ${WRKSRC}/data/qmax.ini ${DATADIR}/qmax.ini
+ ${INSTALL_MAN} ${WRKSRC}/${MAN6} ${MANPREFIX}/man/man6
+
+.include <bsd.port.mk>