aboutsummaryrefslogtreecommitdiffstats
path: root/games/falconseye
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /games/falconseye
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'games/falconseye')
-rw-r--r--games/falconseye/Makefile5
-rw-r--r--games/falconseye/files/patch-sys_unix_Makefile_src4
-rw-r--r--games/falconseye/files/x-config4
3 files changed, 6 insertions, 7 deletions
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index cd02f52bddbe..a02d4c0be277 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -9,8 +9,7 @@ PORTNAME= falconseye
PORTVERSION= 1.9.3
PORTREVISION= 6
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= falconseye
+MASTER_SITES= SF/falconseye
DISTNAME= nethack_source_331_jtp_${PORTVERSION:S/.//g}
MAINTAINER= kris@FreeBSD.org
@@ -25,7 +24,7 @@ USE_SDL= sdl
USE_PERL5_BUILD=yes
USE_ZIP= yes
USE_XORG= x11 xpm xaw
-MAKE_ENV+= CFLAGS="${CFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include -L${X11BASE}/lib -L${LOCALBASE}/lib -I${LOCALBASE}/include/SDL11" PREFIX="${PREFIX}" X11BASE="${X11BASE}"
+MAKE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib -I${LOCALBASE}/include/SDL11" PREFIX="${PREFIX}"
WRKSRC= ${WRKDIR}
post-patch:
diff --git a/games/falconseye/files/patch-sys_unix_Makefile_src b/games/falconseye/files/patch-sys_unix_Makefile_src
index 0a5f9aab8074..c29bd48cb73a 100644
--- a/games/falconseye/files/patch-sys_unix_Makefile_src
+++ b/games/falconseye/files/patch-sys_unix_Makefile_src
@@ -14,8 +14,8 @@
# compile normally
-CFLAGS = -O2 -fomit-frame-pointer -I../include -I/usr/X11/include
-LFLAGS = -L/usr/X11/lib
-+CFLAGS += -I../include -I${X11BASE}/include -DHACKDIR=\"${NHDIR}\" -DHAVE_SYS_PARAM_H
-+LFLAGS = -L${X11BASE}/lib
++CFLAGS += -I../include -I${LOCALBASE}/include -DHACKDIR=\"${NHDIR}\" -DHAVE_SYS_PARAM_H
++LFLAGS = -L${LOCALBASE}/lib
# OR compile backwards compatible a.out format
# CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include -I/usr/X11/include
# LFLAGS = -b i486-linuxaout -L/usr/X11/lib
diff --git a/games/falconseye/files/x-config b/games/falconseye/files/x-config
index ad90b1f0b35a..acfae4384f56 100644
--- a/games/falconseye/files/x-config
+++ b/games/falconseye/files/x-config
@@ -1,6 +1,6 @@
VARDATND = x11tiles pet_mark.xbm rip.xpm
-CFLAGS+=-DX11_GRAPHICS -I${X11BASE}/include
-LFLAGS =-L${X11BASE}/lib
+CFLAGS+=-DX11_GRAPHICS -I${LOCALBASE}/include
+LFLAGS =-L${LOCALBASE}/lib
WINSRC = $(WINTTYSRC) $(WINX11SRC)
WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)