aboutsummaryrefslogtreecommitdiffstats
path: root/games/fbg2/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-05-18 12:42:31 +0800
committermiwi <miwi@FreeBSD.org>2012-05-18 12:42:31 +0800
commitbedcb06c98d72261b5936014982c2545f299e1ea (patch)
tree68183dd4dfd6ccdf53e27f46d5e12c517d890fbb /games/fbg2/Makefile
parent6466f17ff23e74854daf95abb46819ac011c3d1e (diff)
downloadfreebsd-ports-gnome-bedcb06c98d72261b5936014982c2545f299e1ea.tar.gz
freebsd-ports-gnome-bedcb06c98d72261b5936014982c2545f299e1ea.tar.zst
freebsd-ports-gnome-bedcb06c98d72261b5936014982c2545f299e1ea.zip
Falling Block Game is a free, open source block stacking game available for
Windows and Linux. The object of the game is to move and rotate pieces in order to fill in complete rows. The more rows you clear at once, the more points you score! WWW: http://fbg.sourceforge.net/ PR: ports/168086 Submitted by: nemysis@gmx.ch
Diffstat (limited to 'games/fbg2/Makefile')
-rw-r--r--games/fbg2/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/games/fbg2/Makefile b/games/fbg2/Makefile
new file mode 100644
index 000000000000..1d2c00da0115
--- /dev/null
+++ b/games/fbg2/Makefile
@@ -0,0 +1,49 @@
+# New Ports collection makefile for: Falling Block Game
+# Date created: 2012-05-18
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= fbg2
+PORTVERSION= 0.4
+CATEGORIES= games
+MASTER_SITES= SF/fbg/
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Classic block-stacking arcade game
+
+LICENSE= GPLv2 CCbyNCSA3
+LICENSE_COMB= dual
+LICENSE_NAME_CCbyNCSA3=Attribution-NonCommercial-ShareAlike 3.0 Unported
+LICENSE_FILE= ${WRKSRC}/License.txt
+LICENSE_FILE_CCbyNCSA3=${WRKSRC}/License.txt
+LICENSE_PERMS_CCbyNCSA3=dist-mirror pkg-mirror auto-accept
+
+LIB_DEPENDS= radius:${PORTSDIR}/graphics/radius-engine \
+ lua-5.1:${PORTSDIR}/lang/lua \
+ png:${PORTSDIR}/graphics/png \
+ physfs.1:${PORTSDIR}/devel/physfs
+RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
+
+GNU_CONFIGURE= yes
+ALL_TARGET= ${PORTNAME}
+USE_SDL= sdl sound
+USE_GL= glu
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/applications/${PORTNAME}.desktop \
+ share/pixmaps/${PORTNAME}.png
+PLIST_DIRSTRY= share/applications
+
+PORTDATA= *
+PORTDOCS= ChangeLog
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>