aboutsummaryrefslogtreecommitdiffstats
path: root/games/fgrun
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2009-03-09 01:49:26 +0800
committerlwhsu <lwhsu@FreeBSD.org>2009-03-09 01:49:26 +0800
commita16782ab9f1007df2410b82d7050ecb7263e1bca (patch)
tree76dd269a2fbdcfcb52380a6036ce367e2caefa6b /games/fgrun
parent2d6830e542cebd37e13816ec8b0ec2788e63e04c (diff)
downloadfreebsd-ports-gnome-a16782ab9f1007df2410b82d7050ecb7263e1bca.tar.gz
freebsd-ports-gnome-a16782ab9f1007df2410b82d7050ecb7263e1bca.tar.zst
freebsd-ports-gnome-a16782ab9f1007df2410b82d7050ecb7263e1bca.zip
- Update to 1.5.1
PR: ports/131352 Submitted by: Kuan-Chung Chiu <buganini AT gmail.com>
Diffstat (limited to 'games/fgrun')
-rw-r--r--games/fgrun/Makefile13
-rw-r--r--games/fgrun/distinfo6
-rw-r--r--games/fgrun/files/patch-src-run_posix.cxx15
3 files changed, 24 insertions, 10 deletions
diff --git a/games/fgrun/Makefile b/games/fgrun/Makefile
index eef15b5cfd77..1f22bf5ea215 100644
--- a/games/fgrun/Makefile
+++ b/games/fgrun/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fgrun
-PORTVERSION= 1.5.0
+PORTVERSION= 1.5.1
CATEGORIES= games
MASTER_SITES= SF
@@ -14,12 +14,11 @@ MAINTAINER= buganini@gmail.com
COMMENT= A graphical frontend to run FlightGear Flight Simulator
BUILD_DEPENDS= fltk-threads>=1.1.9:${PORTSDIR}/x11-toolkits/fltk-threads \
- osg>=2.6.1:${PORTSDIR}/graphics/osg \
- SimGear>=1.9.0:${PORTSDIR}/devel/simgear \
+ SimGear>=1.9.1:${PORTSDIR}/devel/simgear \
plib>=1.8.5:${PORTSDIR}/x11-toolkits/plib
RUN_DEPENDS= fltk-threads>=1.1.9:${PORTSDIR}/x11-toolkits/fltk-threads \
osg>=2.6.1:${PORTSDIR}/graphics/osg \
- SimGear>=1.9.0:${PORTSDIR}/devel/simgear \
+ SimGear>=1.9.1:${PORTSDIR}/devel/simgear \
fgfs:${PORTSDIR}/games/flightgear \
plib>=1.8.5:${PORTSDIR}/x11-toolkits/plib
@@ -35,6 +34,12 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
+.if defined(WITH_OSG_DEVEL)
+LIB_DEPENDS+= osg.54:${PORTSDIR}/graphics/osg-devel
+.else
+LIB_DEPENDS+= osg.48:${PORTSDIR}/graphics/osg
+.endif
+
post-patch:
.if defined(WITHOUT_NLS)
@${REINPLACE_CMD} 's|SUBDIRS = src po msvc|SUBDIRS = src|' \
diff --git a/games/fgrun/distinfo b/games/fgrun/distinfo
index 3b4f967ecd27..59e215605277 100644
--- a/games/fgrun/distinfo
+++ b/games/fgrun/distinfo
@@ -1,3 +1,3 @@
-MD5 (fgrun-1.5.0.tar.gz) = b338342149c8794079068396dcb9538a
-SHA256 (fgrun-1.5.0.tar.gz) = 15ab80410d277df87c2568f4bdf9725a8442193f0460e9e03fc80f59b7f69e51
-SIZE (fgrun-1.5.0.tar.gz) = 379646
+MD5 (fgrun-1.5.1.tar.gz) = ec56662b2467719924e5667ed24ba419
+SHA256 (fgrun-1.5.1.tar.gz) = a91a7d3494943876e9bc9e67aa5f366f5a6fa1fd5ebdd7ef239280439e4cb2d7
+SIZE (fgrun-1.5.1.tar.gz) = 381289
diff --git a/games/fgrun/files/patch-src-run_posix.cxx b/games/fgrun/files/patch-src-run_posix.cxx
index 180f2479c8e9..db68a8a3a5eb 100644
--- a/games/fgrun/files/patch-src-run_posix.cxx
+++ b/games/fgrun/files/patch-src-run_posix.cxx
@@ -1,6 +1,6 @@
---- src/run_posix.cxx.orig 2008-04-23 04:51:01.000000000 +0800
-+++ src/run_posix.cxx 2008-10-18 17:28:27.000000000 +0800
-@@ -58,7 +58,7 @@
+--- src/run_posix.cxx.orig 2009-01-25 17:01:58.000000000 +0000
++++ src/run_posix.cxx 2009-03-09 01:08:38.080801315 +0000
+@@ -59,7 +59,7 @@
#if defined(HAVE_TERMIOS_H)
struct termios term;
tcgetattr( STDOUT_FILENO, &term );
@@ -9,3 +9,12 @@
pid = pty_fork( &master, 0, &term, 0 );
#else
+@@ -171,7 +171,7 @@
+ #if defined(HAVE_TERMIOS_H)
+ struct termios term;
+ tcgetattr( STDOUT_FILENO, &term );
+- term.c_oflag &= ~( OLCUC | ONLCR );
++ term.c_oflag &= ~ONLCR;
+
+ tsPid = pty_fork( &master, 0, &term, 0 );
+ #else