aboutsummaryrefslogtreecommitdiffstats
path: root/games/fuhquake/files
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
committerobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
commit6b02d1b35c173832c085697cf76aa156d04ad843 (patch)
tree195cb55f1eda849521409154920849cf102b91fa /games/fuhquake/files
parent93ea51bfc3219265c52c39374430d10201b8f436 (diff)
downloadfreebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.gz
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.zst
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.zip
Assist getting more ports working on AMD64 by obeying the
Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'.
Diffstat (limited to 'games/fuhquake/files')
-rw-r--r--games/fuhquake/files/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/games/fuhquake/files/Makefile b/games/fuhquake/files/Makefile
index bb65bf3408c8..589bfc987e0f 100644
--- a/games/fuhquake/files/Makefile
+++ b/games/fuhquake/files/Makefile
@@ -18,7 +18,7 @@ DO_CFLAGS += -DNO_WINDOWED_MOUSE
.undef WITHOUT_X86_ASM
.endif
-.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
DO_CFLAGS += -Did386
.endif
@@ -116,7 +116,7 @@ CL_COMMON_OBJS = \
rulesets.o \
utils.o
-.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
CL_COMMON_AS_OBJS = \
cl_math.o \
math.o \
@@ -154,7 +154,7 @@ CL_SOFT_OBJS = \
r_surf.o \
r_vars.o
-.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
CL_SOFT_AS_OBJS = \
d_draw.o \
d_draw16.o \
@@ -192,7 +192,7 @@ CL_GLX_OBJS = \
CL_SVGA_OBJS = vid_svgalib.o
-.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
CL_SVGA_AS_OBJS = d_copy.o
.endif