aboutsummaryrefslogtreecommitdiffstats
path: root/games/glasteroids/Makefile
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-03-06 20:17:30 +0800
committerkris <kris@FreeBSD.org>2004-03-06 20:17:30 +0800
commite8cc440111a3314b511fe7cd266bd7e919fbd4ce (patch)
treead35d4a01ce78421ba44dc57de1a18fc7372267e /games/glasteroids/Makefile
parentf49d491d64b3d7b880df2b0eb284afe93127b232 (diff)
downloadfreebsd-ports-gnome-e8cc440111a3314b511fe7cd266bd7e919fbd4ce.tar.gz
freebsd-ports-gnome-e8cc440111a3314b511fe7cd266bd7e919fbd4ce.tar.zst
freebsd-ports-gnome-e8cc440111a3314b511fe7cd266bd7e919fbd4ce.zip
BROKEN on amd64: Does not compile
Diffstat (limited to 'games/glasteroids/Makefile')
-rw-r--r--games/glasteroids/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/glasteroids/Makefile b/games/glasteroids/Makefile
index c0dae1f4edb9..87efb65cd33b 100644
--- a/games/glasteroids/Makefile
+++ b/games/glasteroids/Makefile
@@ -25,6 +25,12 @@ MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKEFILE= ${FILESDIR}/Makefile.FreeBSD
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not compile on amd64"
+.endif
+
do-install:
${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/Glasteroids ${PREFIX}/bin/glasteroids
@${MKDIR} ${DATADIR}
@@ -39,4 +45,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>