aboutsummaryrefslogtreecommitdiffstats
path: root/games/glob2/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2005-05-01 05:45:29 +0800
committerthierry <thierry@FreeBSD.org>2005-05-01 05:45:29 +0800
commit26542383aae95213f9499a561a552adbd9a43dbc (patch)
tree94517c4b34741e496c18cd40b86b5f7528d4ce2e /games/glob2/Makefile
parent9dc51d5cc723d703fe9b79212427c4b5c27c007b (diff)
downloadfreebsd-ports-gnome-26542383aae95213f9499a561a552adbd9a43dbc.tar.gz
freebsd-ports-gnome-26542383aae95213f9499a561a552adbd9a43dbc.tar.zst
freebsd-ports-gnome-26542383aae95213f9499a561a552adbd9a43dbc.zip
Upgrade to Alpha14.
Diffstat (limited to 'games/glob2/Makefile')
-rw-r--r--games/glob2/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/games/glob2/Makefile b/games/glob2/Makefile
index ff17a7fdcc30..abd27f8e9024 100644
--- a/games/glob2/Makefile
+++ b/games/glob2/Makefile
@@ -6,23 +6,25 @@
#
PORTNAME= glob2
-PORTVERSION= 0.8.6
+PORTVERSION= 0.8.14
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_GENTOO}
-MASTER_SITE_SUBDIR= distfiles
+MASTER_SITES= http://epfl.ysagoon.com/~glob2/data/
MAINTAINER= thierry@FreeBSD.org
COMMENT= Globulation 2 - a free and innovative strategy game
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
+ speex.3:${PORTSDIR}/audio/speex \
freetype.9:${PORTSDIR}/print/freetype2
USE_SDL= image net sdl
+USE_GL= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib"
USE_GCC= 3.4
+USE_REINPLACE= yes
PLIST_FILES= bin/glob2
@@ -32,7 +34,16 @@ PLIST_FILES= bin/glob2
BROKEN= "Does not build on alpha"
.endif
+pre-configure:
+ @${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|" \
+ ${WRKSRC}/configure
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/glob2 ${PREFIX}/bin
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
.include <bsd.port.post.mk>