aboutsummaryrefslogtreecommitdiffstats
path: root/games/gltron
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
committeredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
commit5d87bf6f020ae3177a26e679d65b5e50f035bbe1 (patch)
treeca9d8a7830bc4c19ec29804b066fc99d81d7488b /games/gltron
parent476102ca837a76b18c930b013cb486ec3f0ce79e (diff)
downloadfreebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.gz
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.zst
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.zip
Properly use SDL everywhere:
USE_SDL=yes -> USE_SDL=sdl (good examles everywhere) WANT_SDL/HAVE_SDL instead of exists(localbase/lib/lib...) See http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/using-sdl.html for more information on how to use USE_SDL, WANT_SDL and HAVE_SDL. PR: follow-ups of ports/55494, ports/61877 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'games/gltron')
-rw-r--r--games/gltron/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/games/gltron/Makefile b/games/gltron/Makefile
index 2feef46aae4d..6a10e3847ab8 100644
--- a/games/gltron/Makefile
+++ b/games/gltron/Makefile
@@ -16,12 +16,11 @@ EXTRACT_SUFX= -source.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= A 3D worm game for two players for X Window System
-LIB_DEPENDS= SDL_sound-1.0.1:${PORTSDIR}/audio/sdl_sound \
- png.5:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_X_PREFIX= yes
USE_GL= yes
-USE_SDL= yes
+USE_SDL= sdl sound
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -33,7 +32,7 @@ CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
.if defined(WITH_SDL_NET)
-LIB_DEPENDS+= SDL_net:${PORTSDIR}/net/sdl_net
+USE_SDL+= net
CONFIGURE_ARGS+= --enable-network
.endif