aboutsummaryrefslogtreecommitdiffstats
path: root/games/gnake
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-08-19 13:45:23 +0800
committerjgh <jgh@FreeBSD.org>2013-08-19 13:45:23 +0800
commit4a025bc2404854c9d7bc78ad281d4f44d2a4316a (patch)
treef700c0e6617feb8bc5facc262b89debbb18c4707 /games/gnake
parent05a010be5fdda54fefeaa3f586939aabaf946218 (diff)
downloadfreebsd-ports-gnome-4a025bc2404854c9d7bc78ad281d4f44d2a4316a.tar.gz
freebsd-ports-gnome-4a025bc2404854c9d7bc78ad281d4f44d2a4316a.tar.zst
freebsd-ports-gnome-4a025bc2404854c9d7bc78ad281d4f44d2a4316a.zip
- shift master_sites around, and use project as primary
- drop default defined docsdir - adopt new options format for docs, and define
Diffstat (limited to 'games/gnake')
-rw-r--r--games/gnake/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/games/gnake/Makefile b/games/gnake/Makefile
index 24b4718de952..930ebc99b3ce 100644
--- a/games/gnake/Makefile
+++ b/games/gnake/Makefile
@@ -4,19 +4,21 @@
PORTNAME= gnake
PORTVERSION= 0.94b
CATEGORIES= games
-MASTER_SITES= LOCAL/chinsan \
- http://lightless.org/files/
+MASTER_SITES= http://lightless.org/files/ \
+ LOCAL/jgh/games/${PORTNAME}/
DISTNAME= Gnake.${PORTVERSION}
MAINTAINER= jgh@FreeBSD.org
COMMENT= Nibbles clone for GNU/Linux and *BSD
LICENSE= GPLv2
+
+OPTIONS_DEFINE= DOCS
+
LDFLAGS+= -L${LOCALBASE}/lib -lncurses
CFLAGS+= -Wall
WRKSRC= ${WRKDIR}/${PORTNAME}
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
PORTDOCS= README
PLIST_FILES= bin/${PORTNAME}
@@ -24,11 +26,13 @@ do-build:
${CC} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/${PORTNAME} \
${WRKSRC}/gnake.c
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>