aboutsummaryrefslogtreecommitdiffstats
path: root/games/gnomebreakout
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-04-05 01:36:58 +0800
committernemysis <nemysis@FreeBSD.org>2014-04-05 01:36:58 +0800
commit9e72d0599da7dd84e476024f3bb0a8239dfab964 (patch)
tree5e7d2baf8cd8911c1c9c050fb8714991a49f7872 /games/gnomebreakout
parentc3938df048531958044d3e6a55fff6162b41f68a (diff)
downloadfreebsd-ports-gnome-9e72d0599da7dd84e476024f3bb0a8239dfab964.tar.gz
freebsd-ports-gnome-9e72d0599da7dd84e476024f3bb0a8239dfab964.tar.zst
freebsd-ports-gnome-9e72d0599da7dd84e476024f3bb0a8239dfab964.zip
- Bump PORTREVISION for dependency change
- Add master site - Transfer maintainership to games@ team - Remove DEPRECATED, EXPIRATION_DATE - Add USE_GCC=yes - Add DOCS and add Option - Install conditional NLS, add Option - Support STAGEDIR and add OPTIONS_SUB - Use patch instead of REINPLACE, remove setuid executable and change add patch-Makefile.in - Change REINPLACE, cosmetical changes - Fix GNU/Linux compatibility, proper install - Fix desktop entry file - Recreate patch with make makepatch - Change pkg-descr - Change pkg-plist
Diffstat (limited to 'games/gnomebreakout')
-rw-r--r--games/gnomebreakout/Makefile40
-rw-r--r--games/gnomebreakout/files/patch-Makefile.in30
-rw-r--r--games/gnomebreakout/files/patch-gnome-breakout.desktop13
-rw-r--r--games/gnomebreakout/files/patch-src__anim.c (renamed from games/gnomebreakout/files/patch-src::anim.c)4
-rw-r--r--games/gnomebreakout/pkg-descr7
-rw-r--r--games/gnomebreakout/pkg-plist13
6 files changed, 82 insertions, 25 deletions
diff --git a/games/gnomebreakout/Makefile b/games/gnomebreakout/Makefile
index 764504c05c7f..26bf3782bb53 100644
--- a/games/gnomebreakout/Makefile
+++ b/games/gnomebreakout/Makefile
@@ -3,31 +3,47 @@
PORTNAME= gnomebreakout
PORTVERSION= 0.5.3
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= games gnome
-MASTER_SITES= http://www.users.on.net/~mipearson/
+MASTER_SITES= SF/${PORTNAME:S/eb/e-b/}/${PORTNAME:S/eb/e-b/}/${PORTVERSION}/ \
+ http://www.users.on.net/~mipearson/
DISTNAME= gnome-breakout-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= games@FreeBSD.org
COMMENT= GNOME version of the classic breakout game
-DEPRECATED= Unmaintained since 2000
-EXPIRATION_DATE= 2014-04-11
USES= pathfix pkgconfig
USE_GNOME= gnomeprefix libgnomeui
GNU_CONFIGURE= yes
+USE_GCC= yes
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lm
-NO_STAGE= yes
+PORTDOCS= AUTHORS ChangeLog NEWS README
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext:run
+
+.include <bsd.port.options.mk>
+
post-patch:
+ @${REINPLACE_CMD} -e 's|-Werror||' ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e \
- 's|games.games|root:games|g' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e \
- 's|-Werror||g' ${WRKSRC}/src/Makefile.in
- @${REINPLACE_CMD} -e \
- 's|@GETTEXT_PACKAGE@|@PACKAGE@|g' ${WRKSRC}/po/Makefile.in.in
+ 's|@GETTEXT_PACKAGE@|@PACKAGE@|' ${WRKSRC}/po/Makefile.in.in
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-DGNOME_DISABLE_DEPRECATED||g ; s|-DGTK_DISABLE_DEPRECATED||g'
+ 's|-DGNOME_DISABLE_DEPRECATED||; s|-DGTK_DISABLE_DEPRECATED||; \
+ s|-DGDK_PIXBUF_DISABLE_DEPRECATED||; s|-DG_DISABLE_DEPRECATED||'
+
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e 's|po src|src|' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/gnomebreakout/files/patch-Makefile.in b/games/gnomebreakout/files/patch-Makefile.in
new file mode 100644
index 000000000000..f250bf85c215
--- /dev/null
+++ b/games/gnomebreakout/files/patch-Makefile.in
@@ -0,0 +1,30 @@
+--- ./Makefile.in.orig 2014-04-04 17:49:31.961202370 +0200
++++ ./Makefile.in 2014-04-04 17:49:40.394104597 +0200
+@@ -91,7 +91,7 @@
+ WARN_CXXFLAGS = @WARN_CXXFLAGS@
+
+ SUBDIRS = po src pixmaps levels
+-scoredir = $(localstatedir)/games
++scoredir = $(localstatedir)/gnome-breakout
+
+ EXTRA_DIST = gnome-breakout.desktop gnome-breakout.png TODO BUGS
+
+@@ -99,7 +99,7 @@
+ iconpixmapdir = $(datadir)/pixmaps
+ iconpixmap_DATA = gnome-breakout.png
+
+-Gamesdir = $(datadir)/gnome/apps/Games
++Gamesdir = $(datadir)/applications
+ Games_DATA = gnome-breakout.desktop
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+@@ -397,9 +397,7 @@
+ install-data-local:
+ -$(mkinstalldirs) $(DESTDIR)$(scoredir)
+ -touch $(DESTDIR)$(scoredir)/gnome-breakout.scores
+- -chown games.games $(DESTDIR)$(scoredir)/gnome-breakout.scores
+ -chmod 0664 $(DESTDIR)$(scoredir)/gnome-breakout.scores
+- -chgrp games $(DESTDIR)$(bindir)/gnome-breakout && chmod 2755 $(DESTDIR)$(bindir)/gnome-breakout
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/games/gnomebreakout/files/patch-gnome-breakout.desktop b/games/gnomebreakout/files/patch-gnome-breakout.desktop
new file mode 100644
index 000000000000..4dab0dddda56
--- /dev/null
+++ b/games/gnomebreakout/files/patch-gnome-breakout.desktop
@@ -0,0 +1,13 @@
+--- ./gnome-breakout.desktop.orig 2003-06-23 12:15:30.000000000 +0200
++++ ./gnome-breakout.desktop 2014-04-04 17:49:31.971201127 +0200
+@@ -6,6 +6,7 @@
+ Comment[tr]=Breakout klasiğinin Gnome teşkili
+ Comment[de]=Das klassische Arcade Spiel Breakout für GNOME
+ Exec=gnome-breakout
+-Icon=gnome-breakout.png
+-Terminal=0
+-Type=Game
++Icon=gnome-breakout
++Terminal=false
++Type=Application
++Categories=Game;BlocksGame;
diff --git a/games/gnomebreakout/files/patch-src::anim.c b/games/gnomebreakout/files/patch-src__anim.c
index 95f0e9fc4874..fbbd5bc8dad6 100644
--- a/games/gnomebreakout/files/patch-src::anim.c
+++ b/games/gnomebreakout/files/patch-src__anim.c
@@ -1,5 +1,5 @@
---- src/anim.c.orig Mon May 10 19:42:51 2004
-+++ src/anim.c Thu May 20 00:26:00 2004
+--- ./src/anim.c.orig 2004-05-10 12:42:51.000000000 +0200
++++ ./src/anim.c 2014-04-04 17:49:31.971201127 +0200
@@ -47,6 +47,7 @@
Animation newanim;
char *fullfilename;
diff --git a/games/gnomebreakout/pkg-descr b/games/gnomebreakout/pkg-descr
index 8d4d32c6619b..5d419f3ec4b2 100644
--- a/games/gnomebreakout/pkg-descr
+++ b/games/gnomebreakout/pkg-descr
@@ -1,5 +1,4 @@
-GNOME Breakout is a clone of the classic arcade game Breakout,
-written for GNOME. Still in development, but very playable, and
-very addictive.
+Breakout (Arkanoid) clone for GNOME.
+Supports level customisation, powerups, and different block types.
-WWW: http://www.users.on.net/mipearson/
+WWW: http://sourceforge.net/projects/gnome-breakout/
diff --git a/games/gnomebreakout/pkg-plist b/games/gnomebreakout/pkg-plist
index 3eda97c8575f..8472311c897a 100644
--- a/games/gnomebreakout/pkg-plist
+++ b/games/gnomebreakout/pkg-plist
@@ -1,6 +1,6 @@
bin/gnome-breakout
-share/gnome/apps/Games/gnome-breakout.desktop
-share/games/gnome-breakout.scores
+share/applications/gnome-breakout.desktop
+share/gnome-breakout/gnome-breakout.scores
share/gnome-breakout/levels/alcaron.gbl
share/gnome-breakout/levels/mdutour.gbl
share/gnome-breakout/levels/mmack.gbl
@@ -67,11 +67,10 @@ share/gnome-breakout/pixmaps/powerup.slow.0.png
share/gnome-breakout/pixmaps/powerup.widebat.0.png
share/gnome-breakout/pixmaps/title.png
share/pixmaps/gnome-breakout.png
-share/locale/de/LC_MESSAGES/gnome-breakout.mo
-share/locale/ru/LC_MESSAGES/gnome-breakout.mo
-share/locale/sv/LC_MESSAGES/gnome-breakout.mo
-share/locale/tr/LC_MESSAGES/gnome-breakout.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gnome-breakout.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gnome-breakout.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gnome-breakout.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/gnome-breakout.mo
@dirrm share/gnome-breakout/pixmaps
@dirrm share/gnome-breakout/levels
@dirrm share/gnome-breakout
-@dirrmtry share/games