aboutsummaryrefslogtreecommitdiffstats
path: root/games/gshisen/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2001-06-26 20:27:31 +0800
committertg <tg@FreeBSD.org>2001-06-26 20:27:31 +0800
commit61a253a56ef753cf3894bf381d4954979ca885ae (patch)
treeab118b59de3502d9047b126afe171f84f3e382e7 /games/gshisen/Makefile
parent0a806dc2c1c594190f14a7132416c38abe00c075 (diff)
downloadfreebsd-ports-gnome-61a253a56ef753cf3894bf381d4954979ca885ae.tar.gz
freebsd-ports-gnome-61a253a56ef753cf3894bf381d4954979ca885ae.tar.zst
freebsd-ports-gnome-61a253a56ef753cf3894bf381d4954979ca885ae.zip
New port gshisen, mahjongg-type game for GNUstep.
Diffstat (limited to 'games/gshisen/Makefile')
-rw-r--r--games/gshisen/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/games/gshisen/Makefile b/games/gshisen/Makefile
new file mode 100644
index 000000000000..a10e3a0e4f71
--- /dev/null
+++ b/games/gshisen/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: GShisen
+# Date created: 12 Jun 2001
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gshisen
+PORTVERSION= 1.0.1
+CATEGORIES= games
+MASTER_SITES= http://www.gnustep.it/enrico/gshisen/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${XGPSBUNDLEDIR}/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu/libgnustep-xgps:${PORTSDIR}/x11-toolkits/gnustep-xgps
+RUN_DEPENDS= ${XGPSBUNDLEDIR}/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu/libgnustep-xgps:${PORTSDIR}/x11-toolkits/gnustep-xgps
+
+PREFIX= ${LOCALBASE}/GNUstep
+WRKSRC= ${WRKDIR}/GShisen
+USE_NEWGCC= yes
+USE_GMAKE= yes
+MAKEFILE=
+MAKE_FLAGS= GUI_BACKEND_LIB=xgps
+ALL_TARGET=
+NO_MTREE= yes
+
+XGPSBUNDLEDIR= ${PREFIX}/System/Library/Bundles/libgnustep-xgps.bundle
+
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "i386"
+GNU_ARCH= ix86
+.else
+GNU_ARCH= ${MACHINE_ARCH}
+.endif
+
+PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L}
+
+do-build:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
+
+do-install:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
+
+.include <bsd.port.post.mk>