aboutsummaryrefslogtreecommitdiffstats
path: root/games/heroes
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /games/heroes
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadfreebsd-ports-gnome-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
freebsd-ports-gnome-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.zst
freebsd-ports-gnome-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'games/heroes')
-rw-r--r--games/heroes/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index 9653339a2ad2..a74d5666414f 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -39,8 +39,7 @@ USE_GMAKE= yes
USE_ICONV= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" \
- MAKEINFO="makeinfo --no-split"
+CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --with-sdl_mixer=${LOCALBASE} --without-gii --without-ggi
MAKE_JOBS_SAFE= yes
@@ -53,8 +52,8 @@ CONFIGURE_ARGS+=--disable-optimizations
MAN6= heroes.6 heroeslvl.6
INFO= heroes
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -lsmpeg ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib -lsmpeg ${PTHREAD_LIBS}
pre-everything::
.ifndef(WITH_OPTIMIZED_CFLAGS)