aboutsummaryrefslogtreecommitdiffstats
path: root/games/khangman
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2011-10-17 08:03:42 +0800
committeravilla <avilla@FreeBSD.org>2011-10-17 08:03:42 +0800
commit18f8d6818a2205ed543432ae7b736e36bb0b1ab5 (patch)
treea38d8a80d7330fafe33e6504e265797c7db5c8ee /games/khangman
parent7e1a35526ca99e8f9cc466c562f4184911eb911c (diff)
downloadfreebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.tar.gz
freebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.tar.zst
freebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.zip
The KDE/FreeBSD team is pleased to announce KDE Software Compilation
4.7.2. The official release notes can be found at: http://kde.org/announcements/announce-4.7.2.php This release ships with many improvements. Read more about them here: http://FreeBSD.kde.org/news.php#itemKDESC472availableinports We'd like to say thanks to all testers and contributors, especially to lwhsu@ for his effort on hosting our test packages. PR: 156293 [1] 159219 [2] 160164 [3] Submitted by: Oleg Sidorkin <osidorkin@gmail.com> [1] Alvaro Castillo <gobledb@gmail.com> [2] dkeav04@gmail.com [3] Tested by: exp-run via pav
Diffstat (limited to 'games/khangman')
-rw-r--r--games/khangman/Makefile31
-rw-r--r--games/khangman/distinfo2
-rw-r--r--games/khangman/pkg-descr10
-rw-r--r--games/khangman/pkg-plist39
4 files changed, 82 insertions, 0 deletions
diff --git a/games/khangman/Makefile b/games/khangman/Makefile
new file mode 100644
index 000000000000..df97ae169a0b
--- /dev/null
+++ b/games/khangman/Makefile
@@ -0,0 +1,31 @@
+# New ports collection Makefile for: khangman
+# Date created: 6 September 2011
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= khangman
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= games kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Hangman game for KDE 4
+
+LIB_DEPENDS= keduvocdocument.5:${PORTSDIR}/misc/libkdeedu
+
+CONFLICTS= kdeedu-4.[0-6].*
+
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+KDE4_BUILDENV= yes
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build qmake_build rcc_build uic_build
+USE_BZIP2= yes
+MAKE_JOBS_SAFE= yes
+
+MAN6= khangman.6
+
+.include <bsd.port.mk>
diff --git a/games/khangman/distinfo b/games/khangman/distinfo
new file mode 100644
index 000000000000..41b5e0c205fb
--- /dev/null
+++ b/games/khangman/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/khangman-4.7.2.tar.bz2) = 7a9656b88bd9ac805b2fce7278c78a2b1b3a1e0b80fe65485ddbc14a4d773a1f
+SIZE (KDE/khangman-4.7.2.tar.bz2) = 1123286
diff --git a/games/khangman/pkg-descr b/games/khangman/pkg-descr
new file mode 100644
index 000000000000..78f5e86b8e9a
--- /dev/null
+++ b/games/khangman/pkg-descr
@@ -0,0 +1,10 @@
+KHangMan is a game based on the well-known hangman game. It is aimed
+at children aged six and over. The game has several categories of
+words to play with, for example: animals (animals words) and three
+difficulty categories: easy, medium and hard. A word is picked at
+random, the letters are hidden, and you must guess the word by trying
+one letter after another. Each time you guess a wrong letter, part of
+a picture of a hangman is drawn. You must guess the word before being
+hanged! You have 10 tries.
+
+WWW: http://edu.kde.org/khangman
diff --git a/games/khangman/pkg-plist b/games/khangman/pkg-plist
new file mode 100644
index 000000000000..5aa507a9a694
--- /dev/null
+++ b/games/khangman/pkg-plist
@@ -0,0 +1,39 @@
+bin/khangman
+share/applications/kde4/khangman.desktop
+share/apps/khangman/fonts/Domestic_Manners.ttf
+share/apps/khangman/fonts/Dustismo_Roman.ttf
+share/apps/khangman/khangmanui.rc
+share/apps/khangman/pics/desert/khangman_desert.svg
+share/apps/khangman/pics/sea/khangman_sea.svg
+share/apps/khangman/pics/standardthemes.xml
+share/apps/khangman/sounds/EW_Dialogue_Appear.ogg
+share/apps/khangman/sounds/new_game.ogg
+share/config.kcfg/khangman.kcfg
+share/config/khangman.knsrc
+share/doc/HTML/en/khangman/application-exit.png
+share/doc/HTML/en/khangman/common
+share/doc/HTML/en/khangman/document-new.png
+share/doc/HTML/en/khangman/games-hint.png
+share/doc/HTML/en/khangman/getnewstuff.png
+share/doc/HTML/en/khangman/index.cache.bz2
+share/doc/HTML/en/khangman/index.docbook
+share/doc/HTML/en/khangman/khangman-desert.png
+share/doc/HTML/en/khangman/khangman-main.png
+share/doc/HTML/en/khangman/man-khangman.6.docbook
+share/doc/HTML/en/khangman/settings-general.png
+share/doc/HTML/en/khangman/settings-languages.png
+share/doc/HTML/en/khangman/settings-timers.png
+share/icons/hicolor/128x128/apps/khangman.png
+share/icons/hicolor/16x16/apps/khangman.png
+share/icons/hicolor/22x22/apps/khangman.png
+share/icons/hicolor/32x32/apps/khangman.png
+share/icons/hicolor/48x48/apps/khangman.png
+share/icons/hicolor/64x64/apps/khangman.png
+share/icons/hicolor/scalable/apps/khangman.svgz
+@dirrm share/doc/HTML/en/khangman
+@dirrm share/apps/khangman/sounds
+@dirrm share/apps/khangman/pics/sea
+@dirrm share/apps/khangman/pics/desert
+@dirrm share/apps/khangman/pics
+@dirrm share/apps/khangman/fonts
+@dirrm share/apps/khangman