aboutsummaryrefslogtreecommitdiffstats
path: root/games/ladder
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
committerasami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
commitaa52cd921c82a10ec33065084fe0edb5cf8bebbc (patch)
treeb70284a297d2e3c06462e3a3a86166c4371477f9 /games/ladder
parentdd1603cad7e60d10dd91a2f1f918e24ed859ed24 (diff)
downloadfreebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.tar.gz
freebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.tar.zst
freebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.zip
Adjust port Makefiles to new EXTRACT_* variable defaults. See log of
bsd.port.mk rev. 1.304 for details on the change. The fix here is one of the following. (1) Define USE_BZIP2 instead of BUILD_DEPENDS on bzip2 and redefining EXTRACT_* commands. (2) Change ${EXTRACT_CMD} to ${TAR} when the command is obviously calling the "tar" command (i.e., arguments like "-xzf" are spelled out). (3) If ${EXTRACT_CMD} is called directly with ${EXTRACT_BEFORE_ARGS}, add ${EXTRACT_AFTER_ARGS} to the command line as well. (4) If any of EXTRACT_CMD, EXTRACT_BEFORE_ARGS or EXTRACT_AFTER_ARGS is set, define the other two too.
Diffstat (limited to 'games/ladder')
-rw-r--r--games/ladder/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/ladder/Makefile b/games/ladder/Makefile
index c4a7ee501286..a1a8696d77a7 100644
--- a/games/ladder/Makefile
+++ b/games/ladder/Makefile
@@ -3,7 +3,7 @@
# Date created: 18 Feb 1998
# Whom: Stefan Zehl <sec@42.org>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/02/20 05:46:59 steve Exp $
#
DISTNAME= ladder
@@ -18,6 +18,8 @@ MAINTAINER= sec@42.org
RESTRICTED= "possible copyright problems ?"
NO_WRKSUBDIR= true
-EXTRACT_BEFORE_ARGS=-xf
+EXTRACT_CMD= ${TAR}
+EXTRACT_BEFORE_ARGS= -xf
+EXTRACT_AFTER_ARGS= # empty
.include <bsd.port.mk>