aboutsummaryrefslogtreecommitdiffstats
path: root/games/libggz
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /games/libggz
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'games/libggz')
-rw-r--r--games/libggz/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/games/libggz/Makefile b/games/libggz/Makefile
index 032e83b6663e..404582125688 100644
--- a/games/libggz/Makefile
+++ b/games/libggz/Makefile
@@ -19,14 +19,13 @@ LIB_DEPENDS= gcrypt.18:${PORTSDIR}/security/libgcrypt
USE_AUTOTOOLS= libtool
USE_GNOME= gnomehack
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug
USE_LDCONFIG= yes
MAN3= ggz.h.3
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.if defined(WITH_GNUTLS)
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls