aboutsummaryrefslogtreecommitdiffstats
path: root/games/linux-gorky17-demo
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2009-02-07 05:43:27 +0800
committerbeech <beech@FreeBSD.org>2009-02-07 05:43:27 +0800
commitad40c88544a69f76674c90ddeb35d1aaa3d5f29f (patch)
tree3b878ff3fe64c5004196473647125935ded36e15 /games/linux-gorky17-demo
parent01d76eb4092593c3117ccc3e1a01d01118c42c95 (diff)
downloadfreebsd-ports-gnome-ad40c88544a69f76674c90ddeb35d1aaa3d5f29f.tar.gz
freebsd-ports-gnome-ad40c88544a69f76674c90ddeb35d1aaa3d5f29f.tar.zst
freebsd-ports-gnome-ad40c88544a69f76674c90ddeb35d1aaa3d5f29f.zip
A tactical shooter similiar to Jagged Alliance.
You command a small force of NATO soldiers trying to solve the mysteries behind the missing of an earlier team in the small city of Lubin. Once arrived you find the team dead and yoursell surrounded by monsters. WWW: http://www.linuxgamepublishing.com/info.php?id=20 PR: ports/131251 Submitted by: Marcus von Appen <mva at sysfault.org>
Diffstat (limited to 'games/linux-gorky17-demo')
-rw-r--r--games/linux-gorky17-demo/Makefile73
-rw-r--r--games/linux-gorky17-demo/distinfo3
-rw-r--r--games/linux-gorky17-demo/files/gorky17.in4
-rw-r--r--games/linux-gorky17-demo/pkg-descr6
-rw-r--r--games/linux-gorky17-demo/pkg-plist49
5 files changed, 135 insertions, 0 deletions
diff --git a/games/linux-gorky17-demo/Makefile b/games/linux-gorky17-demo/Makefile
new file mode 100644
index 000000000000..98d5c5cc2d02
--- /dev/null
+++ b/games/linux-gorky17-demo/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: linux-gorky17-demo
+# Date created: 2009-02-01
+# Whom: Marcus von Appen <mva@sysfault.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gorky17-demo
+PORTVERSION= 1.0.1
+CATEGORIES= games linux
+MASTER_SITES= http://demofiles.linuxgamepublishing.com/gorky17/
+PKGNAMEPREFIX= linux-
+DISTNAME= gorky17_demo
+EXTRACT_SUFX= .run
+
+MAINTAINER= mva@sysfault.org
+COMMENT= Gorky17 Demo - a tactical shooter similiar to Jagged Alliance
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg \
+ ${LINUXBASE}/usr/lib/libSDL_mixer-1.2.so.0:${PORTSDIR}/audio/linux-sdl_mixer \
+ ${LINUXBASE}/usr/lib/libmikmod.so.2:${PORTSDIR}/audio/linux-mikmod \
+ ${LINUXBASE}/usr/lib/libogg.so.0:${PORTSDIR}/audio/linux-libogg \
+ ${LINUXBASE}/usr/lib/libvorbis.so.0:${PORTSDIR}/audio/linux-libvorbis
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_XLIB= yes
+NO_CDROM= Redistribution is limited, see license
+NO_BUILD= yes
+
+DATADIR= ${PREFIX}/lib/${PKGNAMEPREFIX}${PORTNAME}
+SUB_FILES= gorky17
+PORTDOCS= README README.licenses EULA
+DATFILES= adjust.dat demo1.jpg demo2.jpg demo3.jpg
+
+OPTIONS= NVIDIA "Install support for nvidia" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NVIDIA)
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
+ ${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
+.else
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+.endif
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @cd ${WRKSRC} && ${TAIL} +377 ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
+ ${TAR} jxf -
+ @cd ${WRKSRC}/data && ${TAR} -xzf ${WRKSRC}/data/data.tar.gz
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/gorky17_demo
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/gorky17_demo.dynamic
+
+do-install:
+ @${MKDIR} ${DATADIR}/bin
+ @cd ${WRKSRC}/bin/Linux/x86 && \
+ ${INSTALL_PROGRAM} gorky17_demo gorky17_demo.dynamic ${DATADIR}/bin
+ @${CP} -R ${WRKSRC}/data/avi ${DATADIR}/
+ @${CP} -R ${WRKSRC}/data/dat ${DATADIR}/
+.for file in ${DATFILES}
+ @${INSTALL_DATA} ${WRKSRC}/data/${file} ${DATADIR}/${file}
+.endfor
+ @${INSTALL_PROGRAM} ${WRKDIR}/gorky17 ${PREFIX}/bin/${PKGNAMEPREFIX}gorky17
+.if !defined (NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/linux-gorky17-demo/distinfo b/games/linux-gorky17-demo/distinfo
new file mode 100644
index 000000000000..1c168e955282
--- /dev/null
+++ b/games/linux-gorky17-demo/distinfo
@@ -0,0 +1,3 @@
+MD5 (gorky17_demo.run) = b4d417a44d59d74e0731c35ef2320034
+SHA256 (gorky17_demo.run) = 8d136a8a867190b1f456b4428579f4b479a4670e0f07c46e9c70db12e691e2a4
+SIZE (gorky17_demo.run) = 158722638
diff --git a/games/linux-gorky17-demo/files/gorky17.in b/games/linux-gorky17-demo/files/gorky17.in
new file mode 100644
index 000000000000..37812f486223
--- /dev/null
+++ b/games/linux-gorky17-demo/files/gorky17.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd %%DATADIR%% || exit 1
+exec ./bin/gorky17_demo "$@"
diff --git a/games/linux-gorky17-demo/pkg-descr b/games/linux-gorky17-demo/pkg-descr
new file mode 100644
index 000000000000..2520d4f8c406
--- /dev/null
+++ b/games/linux-gorky17-demo/pkg-descr
@@ -0,0 +1,6 @@
+A tactical shooter similiar to Jagged Alliance.
+You command a small force of NATO soldiers trying to solve the mysteries
+behind the missing of an earlier team in the small city of Lubin. Once
+arrived you find the team dead and yoursell surrounded by monsters.
+
+WWW: http://www.linuxgamepublishing.com/info.php?id=20
diff --git a/games/linux-gorky17-demo/pkg-plist b/games/linux-gorky17-demo/pkg-plist
new file mode 100644
index 000000000000..5b28ec5fe000
--- /dev/null
+++ b/games/linux-gorky17-demo/pkg-plist
@@ -0,0 +1,49 @@
+bin/linux-gorky17
+%%DATADIR%%/bin/gorky17_demo
+%%DATADIR%%/bin/gorky17_demo.dynamic
+%%DATADIR%%/avi/intro.mjpg
+%%DATADIR%%/avi/introkon.mjpg
+%%DATADIR%%/avi/logo.mjpg
+%%DATADIR%%/avi/logo1.mjpg
+%%DATADIR%%/avi/logo2.mjpg
+%%DATADIR%%/dat/01__port_bulldozer/other.dat
+%%DATADIR%%/dat/01__port_bulldozer/sprite.dat
+%%DATADIR%%/dat/01__port_castlegate/other.dat
+%%DATADIR%%/dat/01__port_castlegate/sprite.dat
+%%DATADIR%%/dat/01__port_citadel/other.dat
+%%DATADIR%%/dat/01__port_citadel/sprite.dat
+%%DATADIR%%/dat/01__port_heavy/other.dat
+%%DATADIR%%/dat/01__port_heavy/sprite.dat
+%%DATADIR%%/dat/01__port_trabant/other.dat
+%%DATADIR%%/dat/01__port_trabant/sprite.dat
+%%DATADIR%%/dat/01_port/other.dat
+%%DATADIR%%/dat/01_port/sprite.dat
+%%DATADIR%%/dat/01_port_citadel/other.dat
+%%DATADIR%%/dat/01_port_citadel/sprite.dat
+%%DATADIR%%/dat/01_port_tunnel/other.dat
+%%DATADIR%%/dat/01_port_tunnel/sprite.dat
+%%DATADIR%%/dat/01_port_worker/other.dat
+%%DATADIR%%/dat/01_port_worker/sprite.dat
+%%DATADIR%%/dat/common/lang.dat
+%%DATADIR%%/dat/common/other.dat
+%%DATADIR%%/dat/common/sound.dat
+%%DATADIR%%/dat/common/sprite.dat
+%%DATADIR%%/dat/common/voice.dat
+%%DATADIR%%/adjust.dat
+%%DATADIR%%/demo1.jpg
+%%DATADIR%%/demo2.jpg
+%%DATADIR%%/demo3.jpg
+@dirrm %%DATADIR%%/avi
+@dirrm %%DATADIR%%/bin
+@dirrm %%DATADIR%%/dat/01__port_bulldozer
+@dirrm %%DATADIR%%/dat/01__port_castlegate
+@dirrm %%DATADIR%%/dat/01__port_citadel
+@dirrm %%DATADIR%%/dat/01__port_heavy
+@dirrm %%DATADIR%%/dat/01__port_trabant
+@dirrm %%DATADIR%%/dat/01_port
+@dirrm %%DATADIR%%/dat/01_port_citadel
+@dirrm %%DATADIR%%/dat/01_port_tunnel
+@dirrm %%DATADIR%%/dat/01_port_worker
+@dirrm %%DATADIR%%/dat/common
+@dirrm %%DATADIR%%/dat
+@dirrm %%DATADIR%%