aboutsummaryrefslogtreecommitdiffstats
path: root/games/linwarrior
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-12-02 06:12:57 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-12-02 06:12:57 +0800
commit3aa37c5febd09b10d14b5691fe57ecd5e3a934a1 (patch)
tree99b219a7b4d000142cdb546ae0bffc00de164a65 /games/linwarrior
parent1dc5a0f60e80340b9d6ca45862ce7bec405eb6b1 (diff)
downloadfreebsd-ports-gnome-3aa37c5febd09b10d14b5691fe57ecd5e3a934a1.tar.gz
freebsd-ports-gnome-3aa37c5febd09b10d14b5691fe57ecd5e3a934a1.tar.zst
freebsd-ports-gnome-3aa37c5febd09b10d14b5691fe57ecd5e3a934a1.zip
- Update to 20091108
Diffstat (limited to 'games/linwarrior')
-rw-r--r--games/linwarrior/Makefile2
-rw-r--r--games/linwarrior/distinfo6
-rw-r--r--games/linwarrior/files/extra-patch-source-cMech.cpp15
-rw-r--r--games/linwarrior/files/patch-Makefile43
4 files changed, 42 insertions, 24 deletions
diff --git a/games/linwarrior/Makefile b/games/linwarrior/Makefile
index 347c66f67b14..8d9e588d6513 100644
--- a/games/linwarrior/Makefile
+++ b/games/linwarrior/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= linwarrior
-PORTVERSION= 20090529
+PORTVERSION= 20091108
CATEGORIES= games
MASTER_SITES= http://www.hackcraft.de/games/linwarrior_3d/downloads/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/games/linwarrior/distinfo b/games/linwarrior/distinfo
index 2ed48837b4d9..d4bc13bf2df4 100644
--- a/games/linwarrior/distinfo
+++ b/games/linwarrior/distinfo
@@ -1,3 +1,3 @@
-MD5 (linwarrior_20090529.tar.gz) = aeb074ecec5f0c90448efd583b6f6909
-SHA256 (linwarrior_20090529.tar.gz) = dcf6243444bb7e3bc13240680ea279ee88977512ac6326f0376190f00ceaf280
-SIZE (linwarrior_20090529.tar.gz) = 3910310
+MD5 (linwarrior_20091108.tar.gz) = c87b00f00443b016a145eeda3a9c2f39
+SHA256 (linwarrior_20091108.tar.gz) = 3edec4ecacc4c7136621de5c83d387db925f5e3035d2e78ed67d16996778e02a
+SIZE (linwarrior_20091108.tar.gz) = 5232855
diff --git a/games/linwarrior/files/extra-patch-source-cMech.cpp b/games/linwarrior/files/extra-patch-source-cMech.cpp
index 6ec323b06a25..54f4677a9113 100644
--- a/games/linwarrior/files/extra-patch-source-cMech.cpp
+++ b/games/linwarrior/files/extra-patch-source-cMech.cpp
@@ -1,6 +1,6 @@
---- source/cMech.cpp.orig 2009-05-23 21:01:21.000000000 +0400
-+++ source/cMech.cpp 2009-06-08 18:39:11.000000000 +0400
-@@ -1756,9 +1756,14 @@
+--- source/cMech.cpp.orig 2009-11-08 16:18:05.000000000 +0300
++++ source/cMech.cpp 2009-11-12 07:03:04.000000000 +0300
+@@ -1494,9 +1494,15 @@
// Set XYZ to Not-A-Number (NaN) for no location.
// Note that NaN-ity can only be tested either by
// isnanf(x), !finite(x) or by x!=x as NaN always != NaN.
@@ -12,9 +12,10 @@
+ uint32_t bits[1];
+ } u;
+ u.bits[0] = 0x7fc00000;
-+ mDestination[0] = u.f;
-+ mDestination[1] = u.f;
-+ mDestination[2] = u.f;
- //printf("Destination is %s\n", (finitef(mDestination[0])) ? "finite" : "infinite" );
++ mDestination[0] = u.f;
++ mDestination[1] = u.f;
++ mDestination[2] = u.f;
++
+ //cout << "Destination is " << ((finitef(mDestination[0])) ? "finite" : "infinite" ) << "\n";
}
}
diff --git a/games/linwarrior/files/patch-Makefile b/games/linwarrior/files/patch-Makefile
index ec84363b0c9c..1e9ed1bc442c 100644
--- a/games/linwarrior/files/patch-Makefile
+++ b/games/linwarrior/files/patch-Makefile
@@ -1,25 +1,42 @@
---- Makefile.orig 2009-02-02 19:09:59.000000000 +0300
-+++ Makefile 2009-02-17 02:45:45.000000000 +0300
-@@ -4,19 +4,18 @@
- MKDIR=mkdir
- CP=cp
- RM=rm -f
--CPP=c++
-+CPP=${CXX}
+--- Makefile.orig 2009-11-08 15:59:15.000000000 +0300
++++ Makefile 2009-12-01 15:07:51.000000000 +0300
+@@ -2,7 +2,7 @@
+ # Makefile with auto-dependency generation
+ # Add Include directories here.
-INCLUDES = -I psi3d -I source -I .
+INCLUDES = -I psi3d -I source -I . `${SDL_CONFIG} --cflags`
- ifneq (,$(findstring Win,$(OS)))
- LIBRARIES= -lmingw32 -lSDLmain -lSDL -lOpenGL32 -lGLU32 -lopenal32 -lalut
- TARGET=dist/linwarrior.exe
+ # Automatic searching for source files.
+ # Objects to compile are all sources (cpp) and put the .o below build-dir.
+@@ -20,18 +20,18 @@
+ LIMITER=$(dir \file)
+ CFLAGS+= -static-libgcc
else
- LIBRARIES= -lGL -lGLU -lSDL -lopenal -lalut
+ LIBRARIES= -lGL -lGLU `${SDL_CONFIG} --libs` -lopenal -lalut
TARGET=dist/linwarrior
+ MKDIR=mkdir
+ RM=rm -f
+ RMREC=rm -f -r
+ CP=cp
+- CPP=c++
++ CPP=${CXX}
+ LIMITER=/
endif
--CFLAGS =-Wp,-M,-MP,-MT,$@,-MF,dep/$(subst /,-,$@).d
- #CFLAGS =-Wp,-M,-MP,-MT,$@,-MF,dep/$(@F).d
+ # Creation of dependency information when compiling.
+-CFLAGS += -Wp,-M,-MP,-MT,$@,-MF,dep/$(subst /,-,$@).d
++CFLAGS +=
+
+ # Print warnings when compiling.
+ CFLAGS += -Wall
+@@ -40,7 +40,7 @@
CFLAGS += $(INCLUDES)
+ # Optimizations.
+-CFLAGS += -O1 -funroll-loops
++CFLAGS +=
+
+ # Default makefile Target.
+ all: $(TARGET)