aboutsummaryrefslogtreecommitdiffstats
path: root/games/maxr/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-12-27 04:23:00 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-12-27 04:23:00 +0800
commit217ec34872c5c9d1861c6bb0f18098e2401e36cc (patch)
treed09ceba51bb3810a9d22e4d533afbe5647712f94 /games/maxr/Makefile
parentec9618d8bb60fbe7579dfdd5012130d5c3d10054 (diff)
downloadfreebsd-ports-gnome-217ec34872c5c9d1861c6bb0f18098e2401e36cc.tar.gz
freebsd-ports-gnome-217ec34872c5c9d1861c6bb0f18098e2401e36cc.tar.zst
freebsd-ports-gnome-217ec34872c5c9d1861c6bb0f18098e2401e36cc.zip
M.A.X.R. (Mechanized Assault and Exploration Reloaded) is a fanproject
by the community of MaxTheGame.de. It was founded by MM (Michael Mönch) around 2006 and became OpenSource at the end of 2007. MAXR is based on the old M.A.X. (Mechanized Assault and Exploration) by Interplay from 1996. WWW: http://www.maxthegame.de/
Diffstat (limited to 'games/maxr/Makefile')
-rw-r--r--games/maxr/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/maxr/Makefile b/games/maxr/Makefile
new file mode 100644
index 000000000000..be5c8ddd3598
--- /dev/null
+++ b/games/maxr/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: maxr
+# Date created: 23 Dec 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= maxr
+PORTVERSION= 0.2.2
+CATEGORIES= games
+MASTER_SITES= http://www.maxthegame.de/downloads/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Mechanized Assault and Exploration Reloaded
+
+GNU_CONFIGURE= yes
+USE_SDL= sdl mixer net
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^LIBS=/ s|-lSDL_|`${SDL_CONFIG} --libs` &|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/SettingsData.*Path =/ s|"\(.*\)"|"${DATADIR}/\1"|' \
+ ${WRKSRC}/src/loaddata.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/maxr ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/data && ${COPYTREE_SHARE} "*" ${DATADIR}
+
+.include <bsd.port.mk>