aboutsummaryrefslogtreecommitdiffstats
path: root/games/minerbold
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-01-25 10:05:57 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-01-25 10:05:57 +0800
commit57b091b498e71fd0ae6487e88438459853b0d02d (patch)
tree632d3af141956e9ab4ac19f7849a051d7970af21 /games/minerbold
parent39668417e51cd68e4666a2b727f2e8d14c66fb53 (diff)
downloadfreebsd-ports-gnome-57b091b498e71fd0ae6487e88438459853b0d02d.tar.gz
freebsd-ports-gnome-57b091b498e71fd0ae6487e88438459853b0d02d.tar.zst
freebsd-ports-gnome-57b091b498e71fd0ae6487e88438459853b0d02d.zip
Remake of Bolder Dash from BK-0010 with INSTEAD engine
WWW: https://github.com/gl00my/minerbold
Diffstat (limited to 'games/minerbold')
-rw-r--r--games/minerbold/Makefile39
-rw-r--r--games/minerbold/distinfo2
-rw-r--r--games/minerbold/pkg-descr3
3 files changed, 44 insertions, 0 deletions
diff --git a/games/minerbold/Makefile b/games/minerbold/Makefile
new file mode 100644
index 000000000000..aa0efc66616e
--- /dev/null
+++ b/games/minerbold/Makefile
@@ -0,0 +1,39 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= minerbold
+PORTVERSION= git20150125
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Remake of Bolder Dash from BK-0010 with INSTEAD engine
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= instead:${PORTSDIR}/games/instead
+
+USE_GITHUB= yes
+GH_ACCOUNT= gl00my
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 49cbad1
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+DATADIR= ${PREFIX}/share/instead/games/${PORTNAME}
+
+PORTDATA= *
+
+DESKTOP_ENTRIES="minerbold" \
+ "" \
+ "${DATADIR}/gfx/04.png" \
+ "${LOCALBASE}/bin/instead ${DATADIR}" \
+ "Game;ArcadeGame;" \
+ ""
+
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "*.lua *.ini gfx snd" \
+ ${STAGEDIR}${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/games/minerbold/distinfo b/games/minerbold/distinfo
new file mode 100644
index 000000000000..88703f0b40b1
--- /dev/null
+++ b/games/minerbold/distinfo
@@ -0,0 +1,2 @@
+SHA256 (minerbold-git20150125.tar.gz) = c47380598153a45b266b1420b7d65c1d16f09aaafd382914ec00ffa9e4331d72
+SIZE (minerbold-git20150125.tar.gz) = 26654
diff --git a/games/minerbold/pkg-descr b/games/minerbold/pkg-descr
new file mode 100644
index 000000000000..de61a8bbc332
--- /dev/null
+++ b/games/minerbold/pkg-descr
@@ -0,0 +1,3 @@
+Remake of Bolder Dash from BK-0010 with INSTEAD engine
+
+WWW: https://github.com/gl00my/minerbold