aboutsummaryrefslogtreecommitdiffstats
path: root/games/miscom/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-10-16 01:00:16 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-10-16 01:00:16 +0800
commit6207c1361b7a1a1545a6ad775e2773f215eac04a (patch)
tree8bc7ce10ea04c9cbaa9867846b061c0617eaf527 /games/miscom/Makefile
parenta74915b4ccb3ae9027b4d6eec4fb7a4c1e9ab10a (diff)
downloadfreebsd-ports-gnome-6207c1361b7a1a1545a6ad775e2773f215eac04a.tar.gz
freebsd-ports-gnome-6207c1361b7a1a1545a6ad775e2773f215eac04a.tar.zst
freebsd-ports-gnome-6207c1361b7a1a1545a6ad775e2773f215eac04a.zip
- Style fixes
- Simplify MASTER_SITES - Clarify LICENSE - Add LICENSE_FILE - Switch to PLIST_FILES/PORTDATA/PORTDOCS
Diffstat (limited to 'games/miscom/Makefile')
-rw-r--r--games/miscom/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/games/miscom/Makefile b/games/miscom/Makefile
index 3ea8b560f175..4abb427a275c 100644
--- a/games/miscom/Makefile
+++ b/games/miscom/Makefile
@@ -1,23 +1,28 @@
# Created by: Andrey Zakhvatov
# $FreeBSD$
-PORTNAME= miscom
-PORTVERSION= 1.0
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= games/arcade
-DISTNAME= ${PORTNAME}
-
-MAINTAINER= ports@FreeBSD.org
+PORTNAME= miscom
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= SUNSITE/games/arcade
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
COMMENT= Atari "Missile Command" clone
-LICENSE= GPLv2
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
-ALL_TARGET=
+ALL_TARGET= # empty
MAKE_ARGS= CC="${CC}" DATADIR="${DATADIR}" \
CFLAGS="${CFLAGS}"
+PLIST_FILES= bin/${PORTNAME} \
+ man/man6/${PORTNAME}.6.gz
+PORTDATA= *
+PORTDOCS= *
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>