aboutsummaryrefslogtreecommitdiffstats
path: root/games/moria/files/patch-unix::Makefile
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2014-06-10 11:22:23 +0800
committerglewis <glewis@FreeBSD.org>2014-06-10 11:22:23 +0800
commit1f32a9d6725f17789e069f0a588e73864c89e66c (patch)
tree4cff44cfc518f1ff504679c79313e1a2d09aa3a6 /games/moria/files/patch-unix::Makefile
parent6e1913bef8526b3ff192d71e4149f642ca0678a2 (diff)
downloadfreebsd-ports-gnome-1f32a9d6725f17789e069f0a588e73864c89e66c.tar.gz
freebsd-ports-gnome-1f32a9d6725f17789e069f0a588e73864c89e66c.tar.zst
freebsd-ports-gnome-1f32a9d6725f17789e069f0a588e73864c89e66c.zip
. Support staging.
Diffstat (limited to 'games/moria/files/patch-unix::Makefile')
-rw-r--r--games/moria/files/patch-unix::Makefile34
1 files changed, 12 insertions, 22 deletions
diff --git a/games/moria/files/patch-unix::Makefile b/games/moria/files/patch-unix::Makefile
index 281059488f5a..b78b568e23ec 100644
--- a/games/moria/files/patch-unix::Makefile
+++ b/games/moria/files/patch-unix::Makefile
@@ -1,19 +1,17 @@
-$FreeBSD$
-
---- unix/Makefile.orig Thu Jul 21 16:37:08 1994
-+++ unix/Makefile Tue Aug 12 10:12:16 2003
-@@ -3,15 +3,15 @@
+--- unix/Makefile.orig 1994-07-21 15:37:08.000000000 -0700
++++ unix/Makefile 2014-06-09 19:44:28.000000000 -0700
+@@ -1,17 +1,13 @@
+ # BINDIR is the directory where the moria binary while be put
+ # LIBDIR is where the other files (score, news, hours) will be put
# LIBDIR must be the same directory defined in config.h
- # OWNER is who you want the game to be chown to.
- # GROUP is who you wnat the game to be chgrp to.
+-# OWNER is who you want the game to be chown to.
+-# GROUP is who you wnat the game to be chgrp to.
-BINDIR = /home/zariski/grabiner/moria
-LIBDIR = /home/zariski/grabiner/moria/files
-OWNER = grabiner
-GROUP = grad
-+BINDIR = %%PREFIX%%/bin
-+LIBDIR = %%PREFIX%%/share/moria/
-+OWNER = games
-+GROUP = games
++BINDIR = ${STAGEDIR}${PREFIX}/bin
++LIBDIR = ${STAGEDIR}${DATADIR}
# For testing and debugging the program, it is best to use this line.
# CFLAGS = -g
@@ -23,7 +21,7 @@ $FreeBSD$
# For BSD Systems
CURSES = -lcurses -ltermcap
-@@ -26,7 +26,7 @@
+@@ -26,7 +22,7 @@
# Normal systems don't require anything here.
LFLAGS =
@@ -32,7 +30,7 @@ $FreeBSD$
SRCS = main.c misc1.c misc2.c misc3.c misc4.c store1.c files.c io.c \
create.c desc.c generate.c sets.c dungeon.c creature.c death.c \
-@@ -60,17 +60,19 @@
+@@ -60,17 +56,11 @@
# you must define BINDIR and LIBDIR before installing
# assumes that BINDIR and LIBDIR exist
install:
@@ -48,18 +46,10 @@ $FreeBSD$
- (cd $(LIBDIR); chown $(OWNER) $(LIBFILES) scores)
- (cd $(LIBDIR); chgrp $(GROUP) $(LIBFILES) scores)
+ -${MKDIR} $(BINDIR)
-+ ${CHMOD} 755 $(BINDIR)
+ ${BSD_INSTALL_PROGRAM} moria $(BINDIR)
-+ ${CHMOD} 4711 $(BINDIR)/moria
+ -${MKDIR} $(LIBDIR)
-+ ${CHMOD} 711 $(LIBDIR)
+ (cd files; ${BSD_INSTALL_DATA} $(LIBFILES) $(LIBDIR))
-+ (cd $(LIBDIR); ${CHMOD} 444 $(LIBFILES))
-+ (cd $(LIBDIR); ${TOUCH} scores; ${CHMOD} 644 scores)
-+ ${CHOWN} $(OWNER) $(BINDIR)/moria
-+ ${CHGRP} $(GROUP) $(BINDIR)/moria
-+ (cd $(LIBDIR); ${CHOWN} $(OWNER) $(LIBFILES) scores)
-+ (cd $(LIBDIR); ${CHGRP} $(GROUP) $(LIBFILES) scores)
++ (cd $(LIBDIR); ${TOUCH} scores)
# If you are short on disk space, or aren't interested in debugging moria.
# strip $(BINDIR)/moria