aboutsummaryrefslogtreecommitdiffstats
path: root/games/naev/Makefile
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2009-04-29 08:11:21 +0800
committeracm <acm@FreeBSD.org>2009-04-29 08:11:21 +0800
commit5a8d10b33f32364ef08f0c16358b91aaff4ca79d (patch)
tree61da39dbd66156e528812367e295537b5fe7df7a /games/naev/Makefile
parent1520f78a800879d748703a5c95ac73361d416943 (diff)
downloadfreebsd-ports-gnome-5a8d10b33f32364ef08f0c16358b91aaff4ca79d.tar.gz
freebsd-ports-gnome-5a8d10b33f32364ef08f0c16358b91aaff4ca79d.tar.zst
freebsd-ports-gnome-5a8d10b33f32364ef08f0c16358b91aaff4ca79d.zip
- New port: games/naev and games/naev-data
NAEV is a 2d action/rpg space game that combines elements from the action, rpg and simulation genres. WWW: http://code.google.com/p/naev/
Diffstat (limited to 'games/naev/Makefile')
-rw-r--r--games/naev/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/games/naev/Makefile b/games/naev/Makefile
new file mode 100644
index 000000000000..f9206e2f87a4
--- /dev/null
+++ b/games/naev/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: naev
+# Date created: 2009-04-26
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= naev
+PORTVERSION= 0.3.9
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= A 2d action/rpg space game
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ freetype:${PORTSDIR}/print/freetype2
+RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/ndata-${PORTVERSION}:${PORTSDIR}/games/naev-data
+
+USE_BZIP2= yes
+USE_DOS2UNIX= conf.example
+USE_GL= gl
+USE_GMAKE= yes
+USE_GNOME= libxml2
+USE_SDL= sdl image mixer
+
+PLIST_FILES= bin/${PORTNAME}
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if !defined(NOPORTDOCS)
+PLIST_FILES+= %%DOCSDIR%%/conf.example
+PLIST_DIRS= %%DOCSDIR%%
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -i "" -e 's|%%DATADIR%%|${DATADIR}|g' -e 's|%%PORTVERSION%%|${PORTVERSION}|g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf.example ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>