aboutsummaryrefslogtreecommitdiffstats
path: root/games/netherearth
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-06-22 06:02:46 +0800
committerrakuco <rakuco@FreeBSD.org>2014-06-22 06:02:46 +0800
commit7fd7733de450ca376e313cd72504eae41ab5f0ee (patch)
treeade1aef6184a01980b8f2a3e433ea9cb069c7294 /games/netherearth
parenta1731fd3b47bd129f913d5f8c71de696c7a00962 (diff)
downloadfreebsd-ports-gnome-7fd7733de450ca376e313cd72504eae41ab5f0ee.tar.gz
freebsd-ports-gnome-7fd7733de450ca376e313cd72504eae41ab5f0ee.tar.zst
freebsd-ports-gnome-7fd7733de450ca376e313cd72504eae41ab5f0ee.zip
- Support staging.
- Apply local patch to avoid a complaint from the compiler: "Function <glutStrokeWidth> called without first calling 'glutInit'." PR: 190833 Submitted by: olevole@olevole.ru (maintainer)
Diffstat (limited to 'games/netherearth')
-rw-r--r--games/netherearth/Makefile15
-rw-r--r--games/netherearth/files/patch-main.cpp21
2 files changed, 28 insertions, 8 deletions
diff --git a/games/netherearth/Makefile b/games/netherearth/Makefile
index 0c4111cbfb91..b38dd6164962 100644
--- a/games/netherearth/Makefile
+++ b/games/netherearth/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netherearth
PORTVERSION= 0.51
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= http://move.kirishi.ru/soft/netherearth/
@@ -15,14 +15,13 @@ GNU_CONFIGURE= yes
USE_GL= glut
USE_SDL= sdl mixer
-NO_STAGE= yes
pre-install:
- if [ ! -d ${PREFIX}/share/netherearth ] ; then \
- ${MKDIR} ${PREFIX}/share/netherearth ;\
+ if [ ! -d ${STAGEDIR}${PREFIX}/share/netherearth ] ; then \
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/netherearth ;\
fi
- ${CP} -R ${WRKSRC}/maps ${PREFIX}/share/netherearth/
- ${CP} -R ${WRKSRC}/models ${PREFIX}/share/netherearth/
- ${CP} -R ${WRKSRC}/sound ${PREFIX}/share/netherearth/
- ${CP} -R ${WRKSRC}/textures ${PREFIX}/share/netherearth/
+ ${CP} -R ${WRKSRC}/maps ${STAGEDIR}${PREFIX}/share/netherearth/
+ ${CP} -R ${WRKSRC}/models ${STAGEDIR}${PREFIX}/share/netherearth/
+ ${CP} -R ${WRKSRC}/sound ${STAGEDIR}${PREFIX}/share/netherearth/
+ ${CP} -R ${WRKSRC}/textures ${STAGEDIR}${PREFIX}/share/netherearth/
.include <bsd.port.mk>
diff --git a/games/netherearth/files/patch-main.cpp b/games/netherearth/files/patch-main.cpp
new file mode 100644
index 000000000000..5553e966d1d6
--- /dev/null
+++ b/games/netherearth/files/patch-main.cpp
@@ -0,0 +1,21 @@
+--- main.cpp.orig 2014-06-09 19:39:33.355708525 +0400
++++ main.cpp 2014-06-09 19:40:20.729705674 +0400
+@@ -20,6 +20,9 @@
+ #include "piece3dobject.h"
+ #include "nether.h"
+
++#include "GL/gl.h"
++#include "GL/glut.h"
++
+ /* GLOBAL VARIABLES INITIALIZATION: */
+
+ int SCREEN_X=640;
+@@ -158,6 +161,8 @@
+ screen_sfc = initialization((fullscreen ? SDL_FULLSCREEN : 0));
+ if (screen_sfc==0) return 0;
+
++ glutInit(&argc, argv);
++
+ time=init_time=SDL_GetTicks();
+
+ while (!quit) {