aboutsummaryrefslogtreecommitdiffstats
path: root/games/openra
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-02-16 16:12:16 +0800
committerjbeich <jbeich@FreeBSD.org>2015-02-16 16:12:16 +0800
commit86234a0d82f97c9200d15a6e3899dd6e4b838924 (patch)
tree15b7fb4d0adb0bb984e8f54f15f7f12e613d3f39 /games/openra
parent147e9032bc5749c91a7a46df4139af27780c186f (diff)
downloadfreebsd-ports-gnome-86234a0d82f97c9200d15a6e3899dd6e4b838924.tar.gz
freebsd-ports-gnome-86234a0d82f97c9200d15a6e3899dd6e4b838924.tar.zst
freebsd-ports-gnome-86234a0d82f97c9200d15a6e3899dd6e4b838924.zip
Improve style/consistency among the ports I maintain
- Convert to COPYTREE_SHARE - Drop unnecessary MKDIR before COPYTREE_SHARE - Drop bsd.port.options.mk if only DOCS requires it without dependencies - Use separate backup if several REINPLACE_CMD against the same file - audio/alsa-utils: convert to LIBS Differential Revision: https://reviews.freebsd.org/D1851 Approved by: bapt (mentor)
Diffstat (limited to 'games/openra')
-rw-r--r--games/openra/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/openra/Makefile b/games/openra/Makefile
index 20a710ca5bdd..2ec30d37e89f 100644
--- a/games/openra/Makefile
+++ b/games/openra/Makefile
@@ -28,7 +28,7 @@ MAKE_ARGS= VERSION="${GH_TAGNAME}"
INSTALL_TARGET= install-all install-linux-shortcuts
DATADIR= ${PREFIX}/lib/${PORTNAME}
PORTDATA= *
-PORTDOCS= *
+PORTDOCS= *.html
OPTIONS_DEFINE= DOCS TEST ZENITY
OPTIONS_DEFAULT=ZENITY
@@ -71,8 +71,8 @@ post-build:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/*.html ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} \
+ "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
.endif
.include <bsd.port.mk>