aboutsummaryrefslogtreecommitdiffstats
path: root/games/openttd
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2016-04-03 13:24:35 +0800
committerdanfe <danfe@FreeBSD.org>2016-04-03 13:24:35 +0800
commit2545388be6ebead6b4a48dd49da20d87f99110a5 (patch)
treedbcc92d2fa1cbbfabc8d2369088cce2a9d1ae0ea /games/openttd
parent20813cbfaf145434983437cc4725bec3fcac6259 (diff)
downloadfreebsd-ports-gnome-2545388be6ebead6b4a48dd49da20d87f99110a5.tar.gz
freebsd-ports-gnome-2545388be6ebead6b4a48dd49da20d87f99110a5.tar.zst
freebsd-ports-gnome-2545388be6ebead6b4a48dd49da20d87f99110a5.zip
Update to version 1.6.0.
Diffstat (limited to 'games/openttd')
-rw-r--r--games/openttd/Makefile2
-rw-r--r--games/openttd/distinfo4
-rw-r--r--games/openttd/files/patch-config.lib28
-rw-r--r--games/openttd/pkg-plist1
4 files changed, 18 insertions, 17 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 34095ad4311f..8d42d362386e 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openttd
-DISTVERSION= 1.5.3
+DISTVERSION= 1.6.0
CATEGORIES= games
MASTER_SITES= http://ca.binaries.openttd.org/binaries/releases/${DISTVERSION}/ \
http://cz.binaries.openttd.org/binaries/releases/${DISTVERSION}/ \
diff --git a/games/openttd/distinfo b/games/openttd/distinfo
index b4ecdad141e1..ce78f6af97b6 100644
--- a/games/openttd/distinfo
+++ b/games/openttd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openttd-1.5.3-source.tar.xz) = d8b9a7aaca7c9f3ff69b1d210daf1e2658402941bb9b30cb2789a9df73d1ba63
-SIZE (openttd-1.5.3-source.tar.xz) = 6568140
+SHA256 (openttd-1.6.0-source.tar.xz) = 4c12e6b516ffdee20a03ebad80dad85d137130002d6d3e123a568376fe4b4eb2
+SIZE (openttd-1.6.0-source.tar.xz) = 6557124
diff --git a/games/openttd/files/patch-config.lib b/games/openttd/files/patch-config.lib
index ee54abfdec0c..3bf0d5a7030f 100644
--- a/games/openttd/files/patch-config.lib
+++ b/games/openttd/files/patch-config.lib
@@ -1,6 +1,6 @@
---- config.lib.orig 2014-06-03 02:26:54 +0800
+--- config.lib.orig 2016-04-01 18:33:55 UTC
+++ config.lib
-@@ -804,15 +804,15 @@ check_params() {
+@@ -816,15 +816,15 @@ check_params() {
pre_detect_with_lzma=$with_lzma
detect_lzma
@@ -18,7 +18,7 @@
log 1 " If you want to compile without lzma use --without-lzma as parameter"
exit
fi
-@@ -1454,7 +1454,6 @@ make_cflags_and_ldflags() {
+@@ -1468,7 +1468,6 @@ make_cflags_and_ldflags() {
# -fomit-frame-pointer and -pg do not go well together (gcc errors they are incompatible)
CFLAGS="-fomit-frame-pointer $CFLAGS"
fi
@@ -26,8 +26,8 @@
else
OBJS_SUBDIR="debug"
-@@ -1664,16 +1663,14 @@ make_cflags_and_ldflags() {
- CFLAGS="$CFLAGS -DWITH_ZLIB"
+@@ -1675,16 +1674,14 @@ make_cflags_and_ldflags() {
+ fi
fi
- if [ -n "$lzma_config" ]; then
@@ -48,7 +48,7 @@
fi
if [ "$with_lzo2" != "0" ]; then
-@@ -2716,6 +2713,10 @@ detect_lzo2() {
+@@ -2692,6 +2689,10 @@ detect_lzo2() {
detect_library "$with_lzo2" "lzo2" "liblzo2.a" "lzo/" "lzo1x.h"
}
@@ -57,9 +57,9 @@
+}
+
detect_libtimidity() {
- detect_library "$with_libtimidity" "libtimidity" "libtimidity.a" "" "timidity.h"
+ detect_pkg_config "$with_libtimidity" "libtimidity" "libtimidity_config" "0.1" "1"
}
-@@ -2772,10 +2773,6 @@ detect_pkg_config() {
+@@ -2756,10 +2757,6 @@ detect_pkg_config() {
log 1 "checking $2... found"
}
@@ -70,13 +70,13 @@
detect_xdg_basedir() {
detect_pkg_config "$with_xdg_basedir" "libxdg-basedir" "xdg_basedir_config" "1.2"
}
-@@ -3669,8 +3666,7 @@ showhelp() {
- echo " --with-cocoa enables COCOA video driver (OSX ONLY)"
- echo " --with-sdl[=sdl-config] enables SDL video driver support"
- echo " --with-zlib[=zlib.a] enables zlib support"
+@@ -3523,8 +3520,7 @@ showhelp() {
+ echo " --with-sdl[=\"pkg-config sdl\"] enables SDL video driver support"
+ echo " --with-zlib[=\"pkg-config zlib\"]"
+ echo " enables zlib support"
- echo " --with-liblzma[=\"pkg-config liblzma\"]"
- echo " enables liblzma support"
+ echo " --with-liblzma[=liblzma.a] enables liblzma support"
echo " --with-liblzo2[=liblzo2.a] enables liblzo2 support"
- echo " --with-png[=libpng-config] enables libpng support"
- echo " --with-freetype[=freetype-config]"
+ echo " --with-png[=\"pkg-config libpng\"]"
+ echo " enables libpng support"
diff --git a/games/openttd/pkg-plist b/games/openttd/pkg-plist
index c781cbb806fe..c4f1543d3eb9 100644
--- a/games/openttd/pkg-plist
+++ b/games/openttd/pkg-plist
@@ -8,6 +8,7 @@ share/pixmaps/openttd.32.xpm
%%DATADIR%%/ai/compat_1.3.nut
%%DATADIR%%/ai/compat_1.4.nut
%%DATADIR%%/ai/compat_1.5.nut
+%%DATADIR%%/ai/compat_1.6.nut
%%DATADIR%%/baseset/no_music.obm
%%DATADIR%%/baseset/no_sound.obs
%%DATADIR%%/baseset/openttd.grf