aboutsummaryrefslogtreecommitdiffstats
path: root/games/openttd
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-04-07 10:49:01 +0800
committerdanfe <danfe@FreeBSD.org>2015-04-07 10:49:01 +0800
commit6aa7b0a57e1277e7c5b7074d9a7cb65d69bfea52 (patch)
tree34b2bd5d90ed66dda8bbf36024c32f1e2bbeb99b /games/openttd
parent4c69d62d60f236546d65f532a8b3eaa928aa0689 (diff)
downloadfreebsd-ports-gnome-6aa7b0a57e1277e7c5b7074d9a7cb65d69bfea52.tar.gz
freebsd-ports-gnome-6aa7b0a57e1277e7c5b7074d9a7cb65d69bfea52.tar.zst
freebsd-ports-gnome-6aa7b0a57e1277e7c5b7074d9a7cb65d69bfea52.zip
- Update to version 1.5.0, fixup optional persistent password saving patch
- Replace references to PORTVERSION with DISTVERSION throughout Makefile to make testing of beta- and RC-versions easier (e.g., just set DISTVERSION= 1.x.y-RCz and go)
Diffstat (limited to 'games/openttd')
-rw-r--r--games/openttd/Makefile15
-rw-r--r--games/openttd/distinfo4
-rw-r--r--games/openttd/files/extra-patch-save-passwords20
-rw-r--r--games/openttd/pkg-plist2
4 files changed, 20 insertions, 21 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 93f08b77b69b..f1a7bbe1e088 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= openttd
-PORTVERSION= 1.4.4
-PORTREVISION= 2
+DISTVERSION= 1.5.0
CATEGORIES= games
-MASTER_SITES= http://gb.binaries.openttd.org/binaries/releases/${PORTVERSION}/ \
- http://ftp.snt.utwente.nl/pub/games/openttd/binaries/releases/${PORTVERSION}/ \
- http://us.binaries.openttd.org/binaries/releases/${PORTVERSION}/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-source
+MASTER_SITES= http://gb.binaries.openttd.org/binaries/releases/${DISTVERSION}/ \
+ http://ftp.snt.utwente.nl/pub/games/openttd/binaries/releases/${DISTVERSION}/ \
+ http://us.binaries.openttd.org/binaries/releases/${DISTVERSION}/
+DISTNAME= ${PORTNAME}-${DISTVERSION}-source
MAINTAINER= danfe@FreeBSD.org
COMMENT= Open source clone of Microprose Transport Tycoon Deluxe
@@ -27,7 +26,7 @@ CONFIGURE_ARGS= --prefix-dir="${PREFIX}" --data-dir="${DATADIR_REL}"
MAKE_ARGS= VERBOSE=1
.endif
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
CXXFLAGS= # Set to empty as OpenTTD treats it as an addition to CFLAGS
SUB_FILES= pkg-message
@@ -92,8 +91,6 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},' ${WRKSRC}/config.lib
- @${REINPLACE_CMD} -e '/FS_NORMAL/s,max(1,&U,' \
- ${WRKSRC}/src/fontcache.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/games/openttd/distinfo b/games/openttd/distinfo
index edacac37a16c..90c2668ae380 100644
--- a/games/openttd/distinfo
+++ b/games/openttd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openttd-1.4.4-source.tar.xz) = 70f430b883c44f5e62111ea2dfd83f4e1c67835d8cd40dbb73bf89becac2d3f7
-SIZE (openttd-1.4.4-source.tar.xz) = 6342508
+SHA256 (openttd-1.5.0-source.tar.xz) = cb2735c3c94709430c58eb4e8820cd5d26b1a17447c34ca8792bb3432a3f7c2d
+SIZE (openttd-1.5.0-source.tar.xz) = 6554560
diff --git a/games/openttd/files/extra-patch-save-passwords b/games/openttd/files/extra-patch-save-passwords
index d4801c2288c4..45b28557d55a 100644
--- a/games/openttd/files/extra-patch-save-passwords
+++ b/games/openttd/files/extra-patch-save-passwords
@@ -1,6 +1,6 @@
--- src/network/network_func.h 2014-10-21 21:36:31.000000000 +0300
+++ src/network/network_func.h 2014-11-09 21:37:49.000000000 +0200
-@@ -73,7 +73,8 @@
+@@ -74,7 +74,8 @@
bool NetworkServerStart();
void NetworkServerNewCompany(const Company *company, NetworkClientInfo *ci);
bool NetworkServerChangeClientName(ClientID client_id, const char *new_name);
@@ -17,11 +17,11 @@
#include "../core/random_func.hpp"
#include "../rev.h"
-
-+#include "../fileio_func.h"
++#include "../fileio_func.h"
+ #include "../safeguards.h"
- /* This file handles all the server-commands */
-@@ -498,6 +498,7 @@
+@@ -500,6 +500,7 @@
/* Reset 'lag' counters */
this->last_frame = this->last_frame_server = _frame_counter;
@@ -29,7 +29,7 @@
Packet *p = new Packet(PACKET_SERVER_NEED_GAME_PASSWORD);
this->SendPacket(p);
return NETWORK_RECV_STATUS_OKAY;
-@@ -1696,6 +1697,9 @@
+@@ -1684,6 +1685,9 @@
IConsolePrintF(CC_DEFAULT, "Auto-removed protection from company #%d", c->index + 1);
_network_company_states[c->index].months_empty = 0;
NetworkServerUpdateCompanyPassworded(c->index, false);
@@ -39,7 +39,7 @@
}
/* Is the company empty for autoclean_novehicles-months, and has no vehicles? */
if (_settings_client.network.autoclean_novehicles != 0 && _network_company_states[c->index].months_empty > _settings_client.network.autoclean_novehicles && vehicles_in_company[c->index] == 0) {
-@@ -1794,6 +1798,9 @@
+@@ -1782,6 +1786,9 @@
strecpy(_network_company_states[company_id].password, password, lastof(_network_company_states[company_id].password));
NetworkServerUpdateCompanyPassworded(company_id, !StrEmpty(_network_company_states[company_id].password));
@@ -49,7 +49,7 @@
}
/**
-@@ -2218,4 +2225,47 @@
+@@ -2206,4 +2213,47 @@
}
}
@@ -99,10 +99,10 @@
#endif /* ENABLE_NETWORK */
--- src/openttd.cpp 2014-10-21 21:36:36.000000000 +0300
+++ src/openttd.cpp 2014-11-09 21:40:39.000000000 +0200
-@@ -1101,6 +1101,10 @@
+@@ -1111,6 +1111,10 @@
#ifdef ENABLE_NETWORK
if (_network_server) {
- snprintf(_network_game_info.map_name, lengthof(_network_game_info.map_name), "%s (Loaded game)", _file_to_saveload.title);
+ seprintf(_network_game_info.map_name, lastof(_network_game_info.map_name), "%s (Loaded game)", _file_to_saveload.title);
+ // Try to load password
+ if ( _settings_client.network.save_password ) {
+ NetworkLoadPassword( );
@@ -122,7 +122,7 @@
};
--- src/table/settings.ini 2014-10-21 21:36:21.000000000 +0300
+++ src/table/settings.ini 2014-11-09 21:37:49.000000000 +0200
-@@ -3874,6 +3874,12 @@
+@@ -3915,6 +3915,12 @@
def = false
cat = SC_EXPERT
diff --git a/games/openttd/pkg-plist b/games/openttd/pkg-plist
index 13619b7a21a1..c781cbb806fe 100644
--- a/games/openttd/pkg-plist
+++ b/games/openttd/pkg-plist
@@ -7,6 +7,7 @@ share/pixmaps/openttd.32.xpm
%%DATADIR%%/ai/compat_1.2.nut
%%DATADIR%%/ai/compat_1.3.nut
%%DATADIR%%/ai/compat_1.4.nut
+%%DATADIR%%/ai/compat_1.5.nut
%%DATADIR%%/baseset/no_music.obm
%%DATADIR%%/baseset/no_sound.obs
%%DATADIR%%/baseset/openttd.grf
@@ -49,6 +50,7 @@ share/pixmaps/openttd.32.xpm
%%DATADIR%%/lang/japanese.lng
%%DATADIR%%/lang/korean.lng
%%DATADIR%%/lang/latvian.lng
+%%DATADIR%%/lang/latin.lng
%%DATADIR%%/lang/lithuanian.lng
%%DATADIR%%/lang/luxembourgish.lng
%%DATADIR%%/lang/malay.lng