aboutsummaryrefslogtreecommitdiffstats
path: root/games/penguin-command/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-06-10 04:55:43 +0800
committerpav <pav@FreeBSD.org>2006-06-10 04:55:43 +0800
commit61f918d20afdd0d1d60b3e7e6425f6383d0f2c23 (patch)
treeaaadbf66d2dac802d36601b388adf2eaa9b4fd22 /games/penguin-command/Makefile
parentb0bfc1e59f05e0c5dba983742b10bd8d1702301e (diff)
downloadfreebsd-ports-gnome-61f918d20afdd0d1d60b3e7e6425f6383d0f2c23.tar.gz
freebsd-ports-gnome-61f918d20afdd0d1d60b3e7e6425f6383d0f2c23.tar.zst
freebsd-ports-gnome-61f918d20afdd0d1d60b3e7e6425f6383d0f2c23.zip
- Update to 1.6.10
- Take maintainership PR: ports/98711 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Diffstat (limited to 'games/penguin-command/Makefile')
-rw-r--r--games/penguin-command/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/games/penguin-command/Makefile b/games/penguin-command/Makefile
index b99539a01af2..8b4d8ba79b42 100644
--- a/games/penguin-command/Makefile
+++ b/games/penguin-command/Makefile
@@ -6,28 +6,26 @@
#
PORTNAME= penguin-command
-PORTVERSION= 1.6.6
-PORTREVISION= 2
+PORTVERSION= 1.6.10
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amdmi3@mail.ru
COMMENT= A clone of the classic game Missile Command
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
-USE_SDL= mixer sdl
+USE_SDL= mixer image sdl
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_TARGET=
+CONFIGURE_ARGS= --program-prefix=""
+
MAN6= penguin-command.6 penguin-command.ja.6
post-patch:
- ${REINPLACE_CMD} 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g' \
- ${WRKSRC}/configure ${WRKSRC}/src/*.[ch]
- ${REINPLACE_CMD} 's/ -lz -lSDL -lm/ -lz -lm/g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's| -lSDL | |g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's|LIBS="-lSDL_image|LIBS="-lSDL_image $$SDL_LIBS|g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>