aboutsummaryrefslogtreecommitdiffstats
path: root/games/pinball
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2015-12-28 00:04:35 +0800
committerthierry <thierry@FreeBSD.org>2015-12-28 00:04:35 +0800
commit0f9d524fc18e7ac75aa4ae6a5344409d8e46cd05 (patch)
treeffba0a034b8b6570515c21768b08b0473346d250 /games/pinball
parent7ccb20e84b132b90107a8381a720cb80f1201f31 (diff)
downloadfreebsd-ports-gnome-0f9d524fc18e7ac75aa4ae6a5344409d8e46cd05.tar.gz
freebsd-ports-gnome-0f9d524fc18e7ac75aa4ae6a5344409d8e46cd05.tar.zst
freebsd-ports-gnome-0f9d524fc18e7ac75aa4ae6a5344409d8e46cd05.zip
Modernize plist and fix highscore handling.
PR: ports/205629 Submitted by: amdmi3
Diffstat (limited to 'games/pinball')
-rw-r--r--games/pinball/Makefile11
-rw-r--r--games/pinball/pkg-plist20
2 files changed, 15 insertions, 16 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index 4ce171c507dc..c256e8639827 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pinball
PORTVERSION= 0.3.1
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -38,10 +38,17 @@ DOCS= README
# For gmake>=3.82
pre-configure:
- ${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
+ @${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
${REINPLACE_CMD} -e 's,^dnl,# dnl,'
post-install:
+ @${MV} ${STAGEDIR}/var/games/pinball/professor/highscores \
+ ${STAGEDIR}/var/games/pinball/professor/highscores.sample
+ @${MV} ${STAGEDIR}/var/games/pinball/tux/highscores \
+ ${STAGEDIR}/var/games/pinball/tux/highscores.sample
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pinball/lib*.so*
+
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
diff --git a/games/pinball/pkg-plist b/games/pinball/pkg-plist
index aad50e23f288..76527510e723 100644
--- a/games/pinball/pkg-plist
+++ b/games/pinball/pkg-plist
@@ -1,4 +1,4 @@
-bin/pinball
+@(,games,2555) bin/pinball
bin/pinball-config
include/pinball/AlignVisitor.h
include/pinball/AllegroVisitor.h
@@ -122,16 +122,8 @@ lib/pinball/libemilia_pin.a
%%DATADIR%%/tux/tiles.png
%%DATADIR%%/tux/tiles.png.pcx
%%DATADIR%%/tux/up.wav
-@dirrm %%DATADIR%%/tux
-@dirrm %%DATADIR%%/professor
-@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm lib/pinball
-@dirrm include/pinball
-@group games
-@unexec rmdir "/var/games/pinball/tux" >/dev/null 2>&1 || :
-@unexec rmdir "/var/games/pinball/professor" >/dev/null 2>&1 || :
-@unexec rmdir "/var/games/pinball" >/dev/null 2>&1 || :
-/var/games/pinball/professor/highscores
-/var/games/pinball/tux/highscores
-@group
+@sample(,games,664) /var/games/pinball/professor/highscores.sample
+@sample(,games,664) /var/games/pinball/tux/highscores.sample
+@dir(,games,775) /var/games/pinball/tux
+@dir(,games,775) /var/games/pinball/professor
+@dir /var/games/pinball