aboutsummaryrefslogtreecommitdiffstats
path: root/games/pinball
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /games/pinball
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'games/pinball')
-rw-r--r--games/pinball/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index e13b1b7e04d9..327cb1384fad 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -9,8 +9,7 @@ PORTNAME= pinball
PORTVERSION= 0.3.1
PORTREVISION= 8
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= thierry@FreeBSD.org
COMMENT= Emilia Pinball is a free pinball game
@@ -25,9 +24,9 @@ LIB_DEPENDS= alleg.42:${PORTSDIR}/devel/allegro
USE_SDL= image mixer sdl
USE_GMAKE= yes
-USE_GL= yes
+USE_GL= gl
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
CONFIGURE_ARGS= --prefix=${PREFIX} --without-debug
@@ -35,8 +34,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --without-debug
CONFIGURE_ARGS+= --with-allegro
EXTRA_LIBS= -lGL -lGLU
.endif
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include -DRZR_LIBSTATIC" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${EXTRA_LIBS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -DRZR_LIBSTATIC" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${EXTRA_LIBS}"
ALLEGRO_CONFIG= ${LOCALBASE}/bin/allegro-config
DOCS= README