aboutsummaryrefslogtreecommitdiffstats
path: root/games/pinball
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /games/pinball
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'games/pinball')
-rw-r--r--games/pinball/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index 02e79bb83365..cb5ad15c8380 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -33,8 +33,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --without-debug
CONFIGURE_ARGS+= --with-allegro
EXTRA_LIBS= -lGL -lGLU
.endif
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -DRZR_LIBSTATIC" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${EXTRA_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include -DRZR_LIBSTATIC
+LDFLAGS+= -L${LOCALBASE}/lib ${EXTRA_LIBS}
MAKE_JOBS_UNSAFE= yes
ALLEGRO_CONFIG= ${LOCALBASE}/bin/allegro-config