aboutsummaryrefslogtreecommitdiffstats
path: root/games/poker-eval
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2006-12-14 23:57:52 +0800
committerijliao <ijliao@FreeBSD.org>2006-12-14 23:57:52 +0800
commit0449cd2b72e35d146587d728d87082ef4d2ed947 (patch)
tree526561be97f0a7ac1d67000bee4fb93ec039a7fa /games/poker-eval
parentcf03749623beb216f9c1d6d43329cc4a56888984 (diff)
downloadfreebsd-ports-gnome-0449cd2b72e35d146587d728d87082ef4d2ed947.tar.gz
freebsd-ports-gnome-0449cd2b72e35d146587d728d87082ef4d2ed947.tar.zst
freebsd-ports-gnome-0449cd2b72e35d146587d728d87082ef4d2ed947.zip
add poker-eval
A C library to evaluate poker hands
Diffstat (limited to 'games/poker-eval')
-rw-r--r--games/poker-eval/Makefile32
-rw-r--r--games/poker-eval/distinfo3
-rw-r--r--games/poker-eval/files/patch-config-ltmain.sh15
-rw-r--r--games/poker-eval/pkg-descr9
-rw-r--r--games/poker-eval/pkg-plist43
5 files changed, 102 insertions, 0 deletions
diff --git a/games/poker-eval/Makefile b/games/poker-eval/Makefile
new file mode 100644
index 000000000000..5fc617b39684
--- /dev/null
+++ b/games/poker-eval/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection Makefile for: poker-eval
+# Date created: Dec 14, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= poker-eval
+PORTVERSION= 0.133
+CATEGORIES= games
+MASTER_SITES= http://download.gna.org/pokersource/sources/
+DISTNAME= ${PORTNAME}-${PORTVERSION:E}.0
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= A C library to evaluate poker hands
+
+USE_GNOME= gnometarget
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= MD5SUM=${MD5}
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|{libdir}/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
+test:
+ @cd ${WRKSRC} && ${GMAKE} check
+
+.include <bsd.port.mk>
diff --git a/games/poker-eval/distinfo b/games/poker-eval/distinfo
new file mode 100644
index 000000000000..0183ac174394
--- /dev/null
+++ b/games/poker-eval/distinfo
@@ -0,0 +1,3 @@
+MD5 (poker-eval-133.0.tar.gz) = a0495760b99d224ac85f9f80e58c4fb5
+SHA256 (poker-eval-133.0.tar.gz) = 5b06fadef4efa2e8d959fba345d1930912a735622f70c3cb898c75f45a2343f0
+SIZE (poker-eval-133.0.tar.gz) = 466897
diff --git a/games/poker-eval/files/patch-config-ltmain.sh b/games/poker-eval/files/patch-config-ltmain.sh
new file mode 100644
index 000000000000..f4e16be60dda
--- /dev/null
+++ b/games/poker-eval/files/patch-config-ltmain.sh
@@ -0,0 +1,15 @@
+--- config/ltmain.sh.orig Thu Dec 14 17:26:54 2006
++++ config/ltmain.sh Thu Dec 14 17:27:08 2006
+@@ -6003,10 +6003,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/games/poker-eval/pkg-descr b/games/poker-eval/pkg-descr
new file mode 100644
index 000000000000..dda668dddd26
--- /dev/null
+++ b/games/poker-eval/pkg-descr
@@ -0,0 +1,9 @@
+poker-eval is a C library to evaluate poker hands. The result of the
+evalution for a given hand is a number. The general idea is that if
+the evalution of your hand is lower than the evaluation of the hand of
+your opponent, you lose. Many poker variants are supported (draw,
+holdem, omaha, etc.) and more can be added. poker-eval is designed
+for speed so that it can be used within poker simulation software
+using either exhaustive exploration or Monte Carlo.
+
+WWW: http://www.pokersource.org/poker-eval.php
diff --git a/games/poker-eval/pkg-plist b/games/poker-eval/pkg-plist
new file mode 100644
index 000000000000..6615f6ff25b2
--- /dev/null
+++ b/games/poker-eval/pkg-plist
@@ -0,0 +1,43 @@
+include/poker-eval/combinations.h
+include/poker-eval/deck.h
+include/poker-eval/deck_astud.h
+include/poker-eval/deck_joker.h
+include/poker-eval/deck_std.h
+include/poker-eval/deck_undef.h
+include/poker-eval/enumdefs.h
+include/poker-eval/enumerate.h
+include/poker-eval/enumord.h
+include/poker-eval/evx_defs.h
+include/poker-eval/game_astud.h
+include/poker-eval/game_joker.h
+include/poker-eval/game_std.h
+include/poker-eval/handval.h
+include/poker-eval/handval_low.h
+include/poker-eval/inlines/eval.h
+include/poker-eval/inlines/eval_astud.h
+include/poker-eval/inlines/eval_joker.h
+include/poker-eval/inlines/eval_joker_low.h
+include/poker-eval/inlines/eval_joker_low8.h
+include/poker-eval/inlines/eval_low.h
+include/poker-eval/inlines/eval_low27.h
+include/poker-eval/inlines/eval_low8.h
+include/poker-eval/inlines/eval_omaha.h
+include/poker-eval/inlines/eval_type.h
+include/poker-eval/inlines/evx5.h
+include/poker-eval/inlines/evx7.h
+include/poker-eval/inlines/evx_action.h
+include/poker-eval/inlines/evx_inlines.h
+include/poker-eval/poker_config.h
+include/poker-eval/poker_defs.h
+include/poker-eval/poker_wrapper.h
+include/poker-eval/pokereval_export.h
+include/poker-eval/rules_astud.h
+include/poker-eval/rules_joker.h
+include/poker-eval/rules_std.h
+include/poker-eval/rules_undef.h
+@dirrm include/poker-eval/inlines
+@dirrm include/poker-eval
+lib/libpoker-eval.a
+lib/libpoker-eval.so
+lib/libpoker-eval.so.1
+libdata/pkgconfig/poker-eval.pc