aboutsummaryrefslogtreecommitdiffstats
path: root/games/prboom/files
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-03-05 16:34:54 +0800
committersem <sem@FreeBSD.org>2005-03-05 16:34:54 +0800
commitbb311f0e645a76661274c7ebaea7c93969356506 (patch)
treec6d71fd514ccf526aa7ac6f64d4b09bcd78d36ab /games/prboom/files
parentf45e4c03218e6021f616d71787fb09a2679f6dc2 (diff)
downloadfreebsd-ports-gnome-bb311f0e645a76661274c7ebaea7c93969356506.tar.gz
freebsd-ports-gnome-bb311f0e645a76661274c7ebaea7c93969356506.tar.zst
freebsd-ports-gnome-bb311f0e645a76661274c7ebaea7c93969356506.zip
- Update to 2.2.6 (fixes build on 5.x)
- Add WITH_GL knob - Pass maintainership to submitter PR: ports/78430 Submitted by: Robin Schoonover <robin.schoonover@gmail.com> Approved by: Jordan DeLong <fracture@allusion.net> (maintainer)
Diffstat (limited to 'games/prboom/files')
-rw-r--r--games/prboom/files/patch-Makefile.in29
-rw-r--r--games/prboom/files/patch-configure32
-rw-r--r--games/prboom/files/patch-data-Makefile.in14
-rw-r--r--games/prboom/files/patch-doc-Makefile.in38
-rw-r--r--games/prboom/files/patch-src-Makefile.in25
5 files changed, 61 insertions, 77 deletions
diff --git a/games/prboom/files/patch-Makefile.in b/games/prboom/files/patch-Makefile.in
index 04ce7de28ba4..da6367ac91ec 100644
--- a/games/prboom/files/patch-Makefile.in
+++ b/games/prboom/files/patch-Makefile.in
@@ -1,25 +1,24 @@
---- Makefile.in.orig Fri Jun 29 03:30:25 2001
-+++ Makefile.in Fri Jun 29 03:31:24 2001
-@@ -167,23 +167,8 @@
- cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
-
+--- Makefile.in.orig Thu Feb 17 13:43:28 2005
++++ Makefile.in Thu Feb 17 13:45:50 2005
+@@ -262,22 +262,8 @@
+ cd $(top_builddir) && $(SHELL) ./config.status $@
+ uninstall-info-am:
install-docDATA: $(doc_DATA)
- @$(NORMAL_INSTALL)
-- $(mkinstalldirs) $(DESTDIR)$(docdir)
+- test -z "$(docdir)" || $(mkdir_p) "$(DESTDIR)$(docdir)"
- @list='$(doc_DATA)'; for p in $$list; do \
-- if test -f $(srcdir)/$$p; then \
-- echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(docdir)/$$p"; \
-- $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(docdir)/$$p; \
-- else if test -f $$p; then \
-- echo " $(INSTALL_DATA) $$p $(DESTDIR)$(docdir)/$$p"; \
-- $(INSTALL_DATA) $$p $(DESTDIR)$(docdir)/$$p; \
-- fi; fi; \
+- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+- f="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(docDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(docdir)/$$f'"; \
+- $(docDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; \
- done
uninstall-docDATA:
- @$(NORMAL_UNINSTALL)
-- list='$(doc_DATA)'; for p in $$list; do \
-- rm -f $(DESTDIR)$(docdir)/$$p; \
+- @list='$(doc_DATA)'; for p in $$list; do \
+- f="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " rm -f '$(DESTDIR)$(docdir)/$$f'"; \
+- rm -f "$(DESTDIR)$(docdir)/$$f"; \
- done
# This directory's subdirectories are mostly independent; you can cd
diff --git a/games/prboom/files/patch-configure b/games/prboom/files/patch-configure
index cda1ea5e866b..8971941c8cdd 100644
--- a/games/prboom/files/patch-configure
+++ b/games/prboom/files/patch-configure
@@ -21,35 +21,3 @@
# Check whether --enable-debug or --disable-debug was given.
if test "${enable_debug+set}" = set; then
enableval="$enable_debug"
-@@ -1250,30 +1250,8 @@
-
-
-
--# Check whether --enable-cpu-opt or --disable-cpu-opt was given.
--if test "${enable_cpu_opt+set}" = set; then
-- enableval="$enable_cpu_opt"
--
--CPU_CFLAGS=""
--
--else
--
--case "$target" in
-- # marginal gains from aligning code
--i386-*) CPU_CFLAGS="-m386" ;;
--i486-*) CPU_CFLAGS="-m486" ;;
-- # nothing special for pentium
-- # CMOV op on ppro/II/686 can help us
--i686-*) CPU_CFLAGS="-mcpu=i686 -march=i686" ;;
--esac
--
--fi
--
--
--
--
- NEW_CFLAGS="$CFLAGS"
--for ac_flag in -Wall -Winline -Wwrite-strings -ffast-math $CFLAGS_OPT $CPU_CFLAGS
-+for ac_flag in -Wall -Winline -Wwrite-strings -ffast-math $CFLAGS_OPT
- do
- echo $ac_n "checking whether compiler supports $ac_flag""... $ac_c" 1>&6
- echo "configure:1280: checking whether compiler supports $ac_flag" >&5
diff --git a/games/prboom/files/patch-data-Makefile.in b/games/prboom/files/patch-data-Makefile.in
index afcc3c95a721..1286cd2ad895 100644
--- a/games/prboom/files/patch-data-Makefile.in
+++ b/games/prboom/files/patch-data-Makefile.in
@@ -1,11 +1,11 @@
---- data/Makefile.in.orig Sun Apr 1 02:14:06 2001
-+++ data/Makefile.in Sun Jun 10 16:49:16 2001
-@@ -91,7 +91,7 @@
- VERSION = @VERSION@
- ac_aux_dir = @ac_aux_dir@
-
+--- data/Makefile.in.orig Thu Feb 17 14:46:13 2005
++++ data/Makefile.in Mon Sep 27 11:31:31 2004
+@@ -163,7 +163,7 @@
+ target_cpu = @target_cpu@
+ target_os = @target_os@
+ target_vendor = @target_vendor@
-waddir = $(datadir)/games/doom
+waddir = $(datadir)/doom
wad_DATA = prboom.wad
EXTRA_DIST = prboom.wad
- mkinstalldirs = $(SHELL) $(top_srcdir)/autotools/mkinstalldirs
+ all: all-am
diff --git a/games/prboom/files/patch-doc-Makefile.in b/games/prboom/files/patch-doc-Makefile.in
index 2cbea1039c2e..c48e3f962417 100644
--- a/games/prboom/files/patch-doc-Makefile.in
+++ b/games/prboom/files/patch-doc-Makefile.in
@@ -1,25 +1,33 @@
---- doc/Makefile.in.orig Sun Apr 1 02:14:05 2001
-+++ doc/Makefile.in Fri Jun 29 03:39:06 2001
-@@ -196,23 +196,9 @@
- $(MAKE) $(AM_MAKEFLAGS) uninstall-man5 uninstall-man6
-
+--- doc/Makefile.in.orig Mon Sep 27 11:31:31 2004
++++ doc/Makefile.in Thu Feb 17 14:55:23 2005
+@@ -32,7 +32,7 @@
+ install_sh_PROGRAM = $(install_sh) -c
+ install_sh_SCRIPT = $(install_sh) -c
+ INSTALL_HEADER = $(INSTALL_DATA)
+-transform = $(program_transform_name)
++transform =
+ NORMAL_INSTALL = :
+ PRE_INSTALL = :
+ POST_INSTALL = :
+@@ -297,22 +297,9 @@
+ rm -f "$(DESTDIR)$(man6dir)/$$inst"; \
+ done
install-docDATA: $(doc_DATA)
- @$(NORMAL_INSTALL)
-- $(mkinstalldirs) $(DESTDIR)$(docdir)
+- test -z "$(docdir)" || $(mkdir_p) "$(DESTDIR)$(docdir)"
- @list='$(doc_DATA)'; for p in $$list; do \
-- if test -f $(srcdir)/$$p; then \
-- echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(docdir)/$$p"; \
-- $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(docdir)/$$p; \
-- else if test -f $$p; then \
-- echo " $(INSTALL_DATA) $$p $(DESTDIR)$(docdir)/$$p"; \
-- $(INSTALL_DATA) $$p $(DESTDIR)$(docdir)/$$p; \
-- fi; fi; \
+- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+- f="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(docDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(docdir)/$$f'"; \
+- $(docDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; \
- done
uninstall-docDATA:
- @$(NORMAL_UNINSTALL)
-- list='$(doc_DATA)'; for p in $$list; do \
-- rm -f $(DESTDIR)$(docdir)/$$p; \
+- @list='$(doc_DATA)'; for p in $$list; do \
+- f="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " rm -f '$(DESTDIR)$(docdir)/$$f'"; \
+- rm -f "$(DESTDIR)$(docdir)/$$f"; \
- done
+
tags: TAGS
diff --git a/games/prboom/files/patch-src-Makefile.in b/games/prboom/files/patch-src-Makefile.in
index bd2a0771dd23..20e8a104d368 100644
--- a/games/prboom/files/patch-src-Makefile.in
+++ b/games/prboom/files/patch-src-Makefile.in
@@ -1,11 +1,20 @@
---- src/Makefile.in.orig Sun Apr 1 02:14:08 2001
-+++ src/Makefile.in Sun Jun 10 16:44:19 2001
-@@ -97,7 +97,7 @@
-
+--- src/Makefile.in.orig Mon Sep 27 11:31:32 2004
++++ src/Makefile.in Thu Feb 17 15:01:16 2005
+@@ -37,7 +37,7 @@
+ install_sh_PROGRAM = $(install_sh) -c
+ install_sh_SCRIPT = $(install_sh) -c
+ INSTALL_HEADER = $(INSTALL_DATA)
+-transform = $(program_transform_name)
++transform =
+ NORMAL_INSTALL = :
+ PRE_INSTALL = :
+ POST_INSTALL = :
+@@ -276,7 +276,7 @@
+ target_vendor = @target_vendor@
+ EXTRA_SUBDIRS = Posix SDL
SUBDIRS = SDL POSIX
-
-gamesdir = $(prefix)/games
+gamesdir = $(prefix)/bin
- EXTRA_PROGRAMS = prboom-game-server
- games_PROGRAMS = prboom @BUILD_SERVER@
-
+ prboom_game_server_SOURCES = d_server.c i_udp_sdl.c protocol.h
+ prboom_game_server_LDADD = POSIX/libposixdoom.a @NET_LIBS@ @SDL_LIBS@
+ COMMON_SRC = \