aboutsummaryrefslogtreecommitdiffstats
path: root/games/py-ski/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-28 03:05:00 +0800
committerkrion <krion@FreeBSD.org>2004-02-28 03:05:00 +0800
commit86ecfc4446a4cd90cda647c1650c96a59e461ea0 (patch)
treeb2acf46f00920ad73c9215a2d3de7da75d999a4e /games/py-ski/Makefile
parent40d1e56f4e884972267b68282002877ebe30f4df (diff)
downloadfreebsd-ports-gnome-86ecfc4446a4cd90cda647c1650c96a59e461ea0.tar.gz
freebsd-ports-gnome-86ecfc4446a4cd90cda647c1650c96a59e461ea0.tar.zst
freebsd-ports-gnome-86ecfc4446a4cd90cda647c1650c96a59e461ea0.zip
Add py-ski 6.5,
Imagine you are skiing down an infinite slope, facing such hazards as trees, ice, bare ground, and the man-eating Yeti! Unfortunately, you have put your jet-powered skis on backwards, so you can't see ahead where you are going; only behind where you have been. However, you can turn to either side, jump or hop through the air, teleport through hyperspace, launch nuclear ICBMs, and cast spells to call the Fire Demon. And since the hazards occur in patches, you can skillfully outmaneuver them. A fun and very silly game that proves you don't need fancy graphical user interfaces to have a good time. WWW: http://catb.org/~esr/ski/ PR: ports/63453 Submitted by: janos.mohacsi@bsd.hu
Diffstat (limited to 'games/py-ski/Makefile')
-rw-r--r--games/py-ski/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/games/py-ski/Makefile b/games/py-ski/Makefile
new file mode 100644
index 000000000000..3e5c195adbbd
--- /dev/null
+++ b/games/py-ski/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-ski
+# Date created: 27 Feb 2004
+# Whom: janos.mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= ski
+PORTVERSION= 6.5
+CATEGORIES= games python
+MASTER_SITES= http://catb.org/~esr/ski/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= Skiing simulation with curses interface in python
+
+USE_PYTHON= yes
+NO_BUILD= yes
+MAN6= ski.6
+PLIST_FILES= bin/ski
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ski ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ski.6 ${PREFIX}/man/man6/
+
+.include <bsd.port.mk>