aboutsummaryrefslogtreecommitdiffstats
path: root/games/quake2-psychomod/Makefile
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-12-26 12:28:41 +0800
committeralepulver <alepulver@FreeBSD.org>2006-12-26 12:28:41 +0800
commit87f3c5b1fb708bcd55aff8744a71f5d93704fcd1 (patch)
tree6d4d714bb6e96d59289afed3585a0b6a071254ba /games/quake2-psychomod/Makefile
parent58ff4de5c61a773cf33e700ad8711518b504167b (diff)
downloadfreebsd-ports-gnome-87f3c5b1fb708bcd55aff8744a71f5d93704fcd1.tar.gz
freebsd-ports-gnome-87f3c5b1fb708bcd55aff8744a71f5d93704fcd1.tar.zst
freebsd-ports-gnome-87f3c5b1fb708bcd55aff8744a71f5d93704fcd1.zip
Psychomod modification for Quake II.
Diffstat (limited to 'games/quake2-psychomod/Makefile')
-rw-r--r--games/quake2-psychomod/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/games/quake2-psychomod/Makefile b/games/quake2-psychomod/Makefile
new file mode 100644
index 000000000000..962193db078f
--- /dev/null
+++ b/games/quake2-psychomod/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: quake2-psychomod
+# Date created: 2006-12-24
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= psychomod
+PORTVERSION= 3.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= alepulver
+PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Psychomod modification for Quake II
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+BUILD_WRKSRC= ${WRKSRC}/src
+ALL_TARGET= release
+
+DOCSDIR= ${PREFIX}/share/doc/${LATEST_LINK}
+
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/__linux__/__unix__/' \
+ ${BUILD_WRKSRC}/q_shared.[ch]
+
+do-install:
+ ${MKDIR} ${Q2DIR}/${PORTNAME}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/psychomod/game.so \
+ ${Q2DIR}/${PORTNAME}
+ cd ${WRKSRC} && ${INSTALL_DATA} *.cfg pak0.pak ${Q2DIR}/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>