aboutsummaryrefslogtreecommitdiffstats
path: root/games/quake2-psychomod/files
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-12-26 12:28:41 +0800
committeralepulver <alepulver@FreeBSD.org>2006-12-26 12:28:41 +0800
commit87f3c5b1fb708bcd55aff8744a71f5d93704fcd1 (patch)
tree6d4d714bb6e96d59289afed3585a0b6a071254ba /games/quake2-psychomod/files
parent58ff4de5c61a773cf33e700ad8711518b504167b (diff)
downloadfreebsd-ports-gnome-87f3c5b1fb708bcd55aff8744a71f5d93704fcd1.tar.gz
freebsd-ports-gnome-87f3c5b1fb708bcd55aff8744a71f5d93704fcd1.tar.zst
freebsd-ports-gnome-87f3c5b1fb708bcd55aff8744a71f5d93704fcd1.zip
Psychomod modification for Quake II.
Diffstat (limited to 'games/quake2-psychomod/files')
-rw-r--r--games/quake2-psychomod/files/patch-src__Makefile71
1 files changed, 71 insertions, 0 deletions
diff --git a/games/quake2-psychomod/files/patch-src__Makefile b/games/quake2-psychomod/files/patch-src__Makefile
new file mode 100644
index 000000000000..3c8b681b5196
--- /dev/null
+++ b/games/quake2-psychomod/files/patch-src__Makefile
@@ -0,0 +1,71 @@
+--- ./src/Makefile.orig Wed Feb 1 20:46:55 2006
++++ ./src/Makefile Sun Dec 24 16:23:24 2006
+@@ -16,20 +16,10 @@
+ # this nice line comes from the linux kernel makefile
+ ARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc/ -e s/sparc64/sparc/ -e s/arm.*/arm/ -e s/sa110/arm/ -e s/alpha/axp/)
+
+-ifneq ($(ARCH),i386)
+-ifneq ($(ARCH),axp)
+-ifneq ($(ARCH),ppc)
+-ifneq ($(ARCH),sparc)
+-$(error arch $(ARCH) is currently not supported)
+-endif
+-endif
+-endif
+-endif
+-
+-BUILD_DEBUG_DIR=debug$(ARCH)
+-BUILD_RELEASE_DIR=release$(ARCH)
++BUILD_DEBUG_DIR=debug
++BUILD_RELEASE_DIR=release
+
+-CC=gcc
++CC?=gcc
+ BASE_CFLAGS=-Dstricmp=strcasecmp
+
+ RELEASE_CFLAGS=$(BASE_CFLAGS) -ffast-math -funroll-loops \
+@@ -53,7 +43,7 @@
+ DO_CC=$(CC) $(CFLAGS) -o $@ -c $<
+ DO_SHLIB_CC=$(CC) $(CFLAGS) $(SHLIBCFLAGS) -o $@ -c $<
+
+-TARGETS=$(BUILDDIR)/psychomod/game$(ARCH).$(SHLIBEXT)
++TARGETS=$(BUILDDIR)/psychomod/game.$(SHLIBEXT)
+
+ all:
+ @echo
+@@ -64,11 +54,11 @@
+ @echo
+ debug:
+ @-mkdir -p $(BUILD_DEBUG_DIR)/psychomod
+- $(MAKE) targets BUILDDIR=$(BUILD_DEBUG_DIR) CFLAGS="$(DEBUG_CFLAGS)"
++ $(MAKE) targets BUILDDIR=$(BUILD_DEBUG_DIR) CFLAGS+="$(DEBUG_CFLAGS)"
+
+ release:
+ @-mkdir -p $(BUILD_RELEASE_DIR)/psychomod
+- $(MAKE) targets BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS="$(RELEASE_CFLAGS)"
++ $(MAKE) targets BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS+="$(RELEASE_CFLAGS)"
+
+ targets: $(TARGETS)
+
+@@ -124,7 +114,7 @@
+ $(BUILDDIR)/p_weapon.o \
+ $(BUILDDIR)/q_shared.o
+
+-$(BUILDDIR)/psychomod/game$(ARCH).$(SHLIBEXT) : $(GAME_OBJS)
++$(BUILDDIR)/psychomod/game.$(SHLIBEXT) : $(GAME_OBJS)
+ $(CC) $(CFLAGS) $(SHLIBLDFLAGS) -o $@ $(GAME_OBJS)
+
+ $(BUILDDIR)/g_ai.o : g_ai.c
+@@ -282,10 +272,10 @@
+ clean: clean-debug clean-release
+
+ clean-debug:
+- $(MAKE) clean2 BUILDDIR=$(BUILD_DEBUG_DIR) CFLAGS="$(DEBUG_CFLAGS)"
++ $(MAKE) clean2 BUILDDIR=$(BUILD_DEBUG_DIR) CFLAGS+="$(DEBUG_CFLAGS)"
+
+ clean-release:
+- $(MAKE) clean2 BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS="$(DEBUG_CFLAGS)"
++ $(MAKE) clean2 BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS+="$(DEBUG_CFLAGS)"
+
+ clean2:
+ -rm -f $(GAME_OBJS)