aboutsummaryrefslogtreecommitdiffstats
path: root/games/quake3
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-11-28 20:04:12 +0800
committeredwin <edwin@FreeBSD.org>2005-11-28 20:04:12 +0800
commit84ee93a085e1f47d07b6fff809e368fedfec092a (patch)
treecf91362dd21ddd994dff36c5ccc582d4b9e52e56 /games/quake3
parente55e86e793ad8b8a781d9bd9a8fd7db724dc1c90 (diff)
downloadfreebsd-ports-gnome-84ee93a085e1f47d07b6fff809e368fedfec092a.tar.gz
freebsd-ports-gnome-84ee93a085e1f47d07b6fff809e368fedfec092a.tar.zst
freebsd-ports-gnome-84ee93a085e1f47d07b6fff809e368fedfec092a.zip
Remove i386 specific parts from the Makefiles.
PR: ports/89603 Submitted by: Linas Valiukas <shirshegsm@gmail.com>
Diffstat (limited to 'games/quake3')
-rw-r--r--games/quake3/Makefile2
-rw-r--r--games/quake3/files/patch-code-Construct2
-rw-r--r--games/quake3/files/patch-code-unix-Makefile6
3 files changed, 5 insertions, 5 deletions
diff --git a/games/quake3/Makefile b/games/quake3/Makefile
index 00dad03d14da..87f90ca03f09 100644
--- a/games/quake3/Makefile
+++ b/games/quake3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quake3
PORTVERSION= 1.32b
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= ftp://ftp.idsoftware.com/idstuff/source/ \
http://www.proarena.com/p/ftpx/x8524/quake_3_arena/ \
diff --git a/games/quake3/files/patch-code-Construct b/games/quake3/files/patch-code-Construct
index 5d75e09d9384..8ec4aa967b32 100644
--- a/games/quake3/files/patch-code-Construct
+++ b/games/quake3/files/patch-code-Construct
@@ -49,7 +49,7 @@
else
{
- $BASE_CFLAGS = $COMMON_CFLAGS . '-DNDEBUG -O6 -mcpu=pentiumpro -march=pentium -fomit-frame-pointer -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing -fstrength-reduce ';
-+ $BASE_CFLAGS = $COMMON_CFLAGS . '-DNDEBUG -O6 -march=pentiumpro -march=pentium -fomit-frame-pointer -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce ';
++ $BASE_CFLAGS = $COMMON_CFLAGS . '-DNDEBUG -O6 -fomit-frame-pointer -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce ';
$BSPC_BASE_CFLAGS = $BASE_CFLAGS . '-DLINUX -DBSPC -Dstricmp=strcasecmp ';
}
diff --git a/games/quake3/files/patch-code-unix-Makefile b/games/quake3/files/patch-code-unix-Makefile
index 415a976544fc..47f9174f8a2e 100644
--- a/games/quake3/files/patch-code-unix-Makefile
+++ b/games/quake3/files/patch-code-unix-Makefile
@@ -14,10 +14,10 @@
# NOTE: the -fomit-frame-pointer option leads to an unstable binary on my test box if it was built on the main box
# but building on the Mdk 7.2 baseline seems to work
- RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -mcpu=pentiumpro -march=pentium -fomit-frame-pointer -pipe -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing -fstrength-reduce
-+ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -march=pentiumpro -march=pentium -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
++ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
# TTimo: use this for building on P3 gcc 2.95.3 libc2.2 for all targets (experimental! -fomit-fram-pointer removed)
-# RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -mcpu=pentiumpro -march=pentium -pipe -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing -fstrength-reduce
-+# RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -march=pentiumpro -march=pentium -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
++# RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
endif
endif
@@ -35,7 +35,7 @@
NEWPGCC=/home/raistllin/src/gcc/build/install/bin/gcc
CC=$(shell if [ -f $(NEWPGCC) ]; then echo $(NEWPGCC); else echo pgcc; fi )
-RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -mcpu=pentiumpro -march=pentium -fomit-frame-pointer -pipe -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing - fstrength-reduce
-+RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -march=pentiumpro -march=pentium -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing - fstrength-reduce
++RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing - fstrength-reduce
endif
LIBEXT=a