aboutsummaryrefslogtreecommitdiffstats
path: root/games/quaqut
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-13 02:26:31 +0800
committerpawel <pawel@FreeBSD.org>2014-04-13 02:26:31 +0800
commit52ef1613ca4d39e5d1ca51de839288ddc70c36dd (patch)
tree2f4877399da211773b60580fe252e4177eb60cea /games/quaqut
parent3aa598bdc751e7e27577a05119e3fbf16cdc54cf (diff)
downloadfreebsd-ports-gnome-52ef1613ca4d39e5d1ca51de839288ddc70c36dd.tar.gz
freebsd-ports-gnome-52ef1613ca4d39e5d1ca51de839288ddc70c36dd.tar.zst
freebsd-ports-gnome-52ef1613ca4d39e5d1ca51de839288ddc70c36dd.zip
- Add staging support
- Define DOCS option
Diffstat (limited to 'games/quaqut')
-rw-r--r--games/quaqut/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/games/quaqut/Makefile b/games/quaqut/Makefile
index 385ca0f3a894..1bd1efc0ae76 100644
--- a/games/quaqut/Makefile
+++ b/games/quaqut/Makefile
@@ -9,22 +9,17 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20C%20sources/${PORTNAME}-${PORTVERSION
MAINTAINER= ports@FreeBSD.org
COMMENT= Queries information from Unreal Tournament 2004 game servers
-
HAS_CONFIGURE= yes
USE_RC_SUBR= ${PORTNAME}
-MAN1= ${PORTNAME}.1
PORTDOCS= AUTHORS COPYING ChangeLog README
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
+
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/quaqut.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>