aboutsummaryrefslogtreecommitdiffstats
path: root/games/r1q2
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-01-15 06:27:40 +0800
committeralepulver <alepulver@FreeBSD.org>2007-01-15 06:27:40 +0800
commita6f15491c67a6d0df6f8dcf2bd32e27790d2692d (patch)
tree6269525143b424c9f6273c6428e56a003fe71ff6 /games/r1q2
parente34543288d11531bb1dd6f5616ddcdab88a6c40e (diff)
downloadfreebsd-ports-gnome-a6f15491c67a6d0df6f8dcf2bd32e27790d2692d.tar.gz
freebsd-ports-gnome-a6f15491c67a6d0df6f8dcf2bd32e27790d2692d.tar.zst
freebsd-ports-gnome-a6f15491c67a6d0df6f8dcf2bd32e27790d2692d.zip
- Update to version 6990.
- Fix wrong error message in net_udp.c (accidentaly introduced by me when disabling the Linux code). Reported by: Steve Crowder <steve@crowders.org>
Diffstat (limited to 'games/r1q2')
-rw-r--r--games/r1q2/Makefile2
-rw-r--r--games/r1q2/distinfo6
-rw-r--r--games/r1q2/files/patch-linux__net_udp.c24
3 files changed, 20 insertions, 12 deletions
diff --git a/games/r1q2/Makefile b/games/r1q2/Makefile
index 95adf43e1c6f..980f08de0f3b 100644
--- a/games/r1q2/Makefile
+++ b/games/r1q2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= r1q2
-PORTVERSION= 6974
+PORTVERSION= 6990
CATEGORIES= games
MASTER_SITES= http://www.r1ch.net/stuff/r1q2/src/
DISTNAME= ${PORTNAME}-b${PORTVERSION}-src
diff --git a/games/r1q2/distinfo b/games/r1q2/distinfo
index 68e4318155c3..782d5360a530 100644
--- a/games/r1q2/distinfo
+++ b/games/r1q2/distinfo
@@ -1,3 +1,3 @@
-MD5 (r1q2-b6974-src.zip) = 05d208d9969098572aff8dc374a89c7c
-SHA256 (r1q2-b6974-src.zip) = 26ae12213779c028971b204b0594697c868d8cf0a758cd1aa8028b0db620fba7
-SIZE (r1q2-b6974-src.zip) = 1121829
+MD5 (r1q2-b6990-src.zip) = a49d70f0ab894226ac1f9d72f6ece531
+SHA256 (r1q2-b6990-src.zip) = 55f7adea1c843aef330d039ebaedb87d3708d4e17e113d7237cd54313ec6c676
+SIZE (r1q2-b6990-src.zip) = 1122118
diff --git a/games/r1q2/files/patch-linux__net_udp.c b/games/r1q2/files/patch-linux__net_udp.c
index 4bd88480b723..e6cb8ff8aef6 100644
--- a/games/r1q2/files/patch-linux__net_udp.c
+++ b/games/r1q2/files/patch-linux__net_udp.c
@@ -1,5 +1,5 @@
---- linux/net_udp.c.orig Fri Jan 12 23:46:14 2007
-+++ linux/net_udp.c Fri Jan 12 23:59:49 2007
+--- linux/net_udp.c.orig Sun Jan 14 16:56:54 2007
++++ linux/net_udp.c Sun Jan 14 18:17:28 2007
@@ -13,8 +13,12 @@
#include <sys/uio.h>
#include <errno.h>
@@ -21,21 +21,29 @@
//linux makes this needlessly complex, couldn't just return the source of the error in from, oh no...
struct probehdr rcvbuf;
struct iovec iov;
-@@ -308,9 +313,10 @@
+@@ -308,9 +313,19 @@
continue;
}
}
--
++#else
++ err = errno;
+
- //errno = err;
- //Com_Printf ("NET_GetPacket: %s\n", LOG_NET, NET_ErrorString());
-+#else
-+ errno = err;
++ if (err == EWOULDBLOCK)
++ return 0;
++ if (err == ECONNREFUSED)
++ {
++ SockadrToNetadr (&from, net_from);
++ Com_Printf ("NET_GetPacket: %s from %s\n", LOG_NET, NET_ErrorString(), NET_AdrToString (net_from));
++ return -1;
++ }
+ Com_Printf ("NET_GetPacket: %s\n", LOG_NET, NET_ErrorString());
+#endif
return 0;
}
-@@ -426,6 +432,7 @@
+@@ -426,6 +441,7 @@
return 0;
}
@@ -43,7 +51,7 @@
// r1: accept icmp unreachables for quick disconnects
if (!net_no_recverr->intvalue)
{
-@@ -434,6 +441,7 @@
+@@ -434,6 +450,7 @@
Com_Printf ("UDP_OpenSocket: Couldn't set IP_RECVERR: %s\n", LOG_NET, NET_ErrorString());
}
}