aboutsummaryrefslogtreecommitdiffstats
path: root/games/railroad-rampage
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-11-08 11:32:10 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-11-08 11:32:10 +0800
commit5a739ae57561545bac13e89f0b2564c95ba1581b (patch)
tree7598fa9fd64dec6dc00bb7f58416d1b65c964f45 /games/railroad-rampage
parent4d59942399310a89f8256918b36047048d670563 (diff)
downloadfreebsd-ports-gnome-5a739ae57561545bac13e89f0b2564c95ba1581b.tar.gz
freebsd-ports-gnome-5a739ae57561545bac13e89f0b2564c95ba1581b.tar.zst
freebsd-ports-gnome-5a739ae57561545bac13e89f0b2564c95ba1581b.zip
Railroad Rampage is a cross between an arcade game and a strategy
game. It is similiar in construction to many "Tower Defence" games, but it has a twist: here, you are part of the action and can affect the game in many different ways more than just building structures. Bandits are trying to rob your train and steal all precious cargo! Thankfully, you are a skilled engineer who can construct many different kinds of turrets and use them to defend your train. You have to make it through 20 waves of relentless enemy assault before you reach your destination, so plan ahead and devise a smart strategy and you may survive! WWW: http://neotron-games.blogspot.com/2009/10/railroad-rampage.html
Diffstat (limited to 'games/railroad-rampage')
-rw-r--r--games/railroad-rampage/Makefile53
-rw-r--r--games/railroad-rampage/distinfo3
-rw-r--r--games/railroad-rampage/files/railroad-rampage.in7
-rw-r--r--games/railroad-rampage/pkg-descr12
-rw-r--r--games/railroad-rampage/pkg-plist22
5 files changed, 97 insertions, 0 deletions
diff --git a/games/railroad-rampage/Makefile b/games/railroad-rampage/Makefile
new file mode 100644
index 000000000000..ff80b40e26c3
--- /dev/null
+++ b/games/railroad-rampage/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: railroad-rampage
+# Date created: 08 Nov 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= railroad-rampage
+PORTVERSION= 1.1
+CATEGORIES= games
+MASTER_SITES= http://mirror.amdmi3.ru/distfiles/
+DISTNAME= RailroadRampage_Linux
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Tower Defence-like Arcade and Strategy combination
+
+BUILD_DEPENDS= bgdc:${PORTSDIR}/devel/bennugd-core \
+ ${LOCALBASE}/lib/bennugd/mod_grproc.so:${PORTSDIR}/devel/bennugd-modules
+RUN_DEPENDS= bgdi:${PORTSDIR}/devel/bennugd-core \
+ ${LOCALBASE}/lib/bennugd/mod_grproc.so:${PORTSDIR}/devel/bennugd-modules
+
+USE_ZIP= yes
+MAKE_JOBS_SAFE= yes
+
+SUB_FILES= ${PORTNAME}
+
+PORTDOCS= ReadMe.txt
+
+DESKTOP_ENTRIES="Railroad Rampage" \
+ "Tower Defence-like Arcade and Strategy combination" \
+ "${DATADIR}/RailroadRampage.png" \
+ "railroad-rampage" \
+ "Game;StrategyGame;ArcadeGame;" \
+ false
+
+do-build:
+ cd ${WRKSRC} && ${SETENV} \
+ LD_LIBRARY_PATH=${LOCALBASE}/lib/bennugd \
+ BENNUDIR=${LOCALBASE}/lib/bennugd \
+ ${LOCALBASE}/bin/bgdc RailroadRampage.prg || true
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "Music Sound" ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/traintd.fpg ${WRKSRC}/RailroadRampage.dcb \
+ ${WRKSRC}/RailroadRampage.png ${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ReadMe.txt ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/railroad-rampage/distinfo b/games/railroad-rampage/distinfo
new file mode 100644
index 000000000000..1039d6e09229
--- /dev/null
+++ b/games/railroad-rampage/distinfo
@@ -0,0 +1,3 @@
+MD5 (RailroadRampage_Linux.zip) = 0d836a8e81b2be3888cd6c3f74dfa91a
+SHA256 (RailroadRampage_Linux.zip) = e365d298ce1da85b4c50ef61b58097aaf861c612acdcf6425c7773ba0275df05
+SIZE (RailroadRampage_Linux.zip) = 3308012
diff --git a/games/railroad-rampage/files/railroad-rampage.in b/games/railroad-rampage/files/railroad-rampage.in
new file mode 100644
index 000000000000..5acdad174397
--- /dev/null
+++ b/games/railroad-rampage/files/railroad-rampage.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+DOTDIR=$HOME/.railroad-rampage
+
+mkdir -p $DOTDIR
+
+exec %%LOCALBASE%%/bin/bgdi -i %%DATADIR%% -i $DOTDIR %%DATADIR%%/RailroadRampage.dcb "$@"
diff --git a/games/railroad-rampage/pkg-descr b/games/railroad-rampage/pkg-descr
new file mode 100644
index 000000000000..6d09a89b8a5d
--- /dev/null
+++ b/games/railroad-rampage/pkg-descr
@@ -0,0 +1,12 @@
+Railroad Rampage is a cross between an arcade game and a strategy
+game. It is similiar in construction to many "Tower Defence" games,
+but it has a twist: here, you are part of the action and can affect
+the game in many different ways more than just building structures.
+Bandits are trying to rob your train and steal all precious cargo!
+Thankfully, you are a skilled engineer who can construct many
+different kinds of turrets and use them to defend your train. You
+have to make it through 20 waves of relentless enemy assault before
+you reach your destination, so plan ahead and devise a smart strategy
+and you may survive!
+
+WWW: http://neotron-games.blogspot.com/2009/10/railroad-rampage.html
diff --git a/games/railroad-rampage/pkg-plist b/games/railroad-rampage/pkg-plist
new file mode 100644
index 000000000000..e06bd2f5cbd4
--- /dev/null
+++ b/games/railroad-rampage/pkg-plist
@@ -0,0 +1,22 @@
+bin/railroad-rampage
+%%DATADIR%%/Music/TACOGUN.ogg
+%%DATADIR%%/RailroadRampage.dcb
+%%DATADIR%%/RailroadRampage.png
+%%DATADIR%%/Sound/beam.wav
+%%DATADIR%%/Sound/bip.wav
+%%DATADIR%%/Sound/boing.wav
+%%DATADIR%%/Sound/bounce.wav
+%%DATADIR%%/Sound/explode1.wav
+%%DATADIR%%/Sound/explode2.wav
+%%DATADIR%%/Sound/firework1.wav
+%%DATADIR%%/Sound/firework2.wav
+%%DATADIR%%/Sound/poff.wav
+%%DATADIR%%/Sound/pop.wav
+%%DATADIR%%/Sound/rocket.wav
+%%DATADIR%%/Sound/stretch.wav
+%%DATADIR%%/Sound/train.wav
+%%DATADIR%%/Sound/turn.wav
+%%DATADIR%%/traintd.fpg
+@dirrm %%DATADIR%%/Sound
+@dirrm %%DATADIR%%/Music
+@dirrm %%DATADIR%%