aboutsummaryrefslogtreecommitdiffstats
path: root/games/rtb/files
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-14 15:10:49 +0800
committerkrion <krion@FreeBSD.org>2004-03-14 15:10:49 +0800
commite5a8c1f3ee1d3d0225d5e9b0d58ed422f78a70f8 (patch)
treef552cbe395723e2613f19e213886fcacb106e6ba /games/rtb/files
parentf039873dac01e2c4ec181095cfa7e46d3d096fe3 (diff)
downloadfreebsd-ports-gnome-e5a8c1f3ee1d3d0225d5e9b0d58ed422f78a70f8.tar.gz
freebsd-ports-gnome-e5a8c1f3ee1d3d0225d5e9b0d58ed422f78a70f8.tar.zst
freebsd-ports-gnome-e5a8c1f3ee1d3d0225d5e9b0d58ed422f78a70f8.zip
- Update to version 1.0.6
PR: ports/64213 Submitted by: Ports Fury
Diffstat (limited to 'games/rtb/files')
-rw-r--r--games/rtb/files/patch-Makefile.in20
-rw-r--r--games/rtb/files/patch-ab16
-rw-r--r--games/rtb/files/patch-ac16
-rw-r--r--games/rtb/files/patch-include::fdstream.h18
-rw-r--r--games/rtb/files/patch-po::Makefile.in.in11
-rw-r--r--games/rtb/files/patch-src::Makefile.in15
-rw-r--r--games/rtb/files/patch-src::String.cc10
7 files changed, 74 insertions, 32 deletions
diff --git a/games/rtb/files/patch-Makefile.in b/games/rtb/files/patch-Makefile.in
new file mode 100644
index 000000000000..2cd03c5dbea1
--- /dev/null
+++ b/games/rtb/files/patch-Makefile.in
@@ -0,0 +1,20 @@
+--- Makefile.in.orig Sun Nov 23 03:44:31 2003
++++ Makefile.in Sat Mar 13 02:50:55 2004
+@@ -120,7 +120,7 @@
+ USE_NLS = @USE_NLS@
+ VERSION = @VERSION@
+
+-SUBDIRS = intl po include src doc
++SUBDIRS = intl po include src
+
+ realtimebattledocdir = ${prefix}/doc/RealTimeBattle
+ realtimebattledoc_DATA = README COPYING AUTHORS ChangeLog INSTALL NEWS TODO ABOUT-NLS
+@@ -374,7 +374,7 @@
+ install-exec-am:
+ install-exec: install-exec-recursive
+
+-install-data-am: install-realtimebattledocDATA
++install-data-am:
+ install-data: install-data-recursive
+
+ install-am: all-am
diff --git a/games/rtb/files/patch-ab b/games/rtb/files/patch-ab
deleted file mode 100644
index deb2150a6893..000000000000
--- a/games/rtb/files/patch-ab
+++ /dev/null
@@ -1,16 +0,0 @@
---- Documentation/Makefile.in.orig
-+++ Documentation/Makefile.in
-
-287,288c287,288
-< RealTimeBattle.html RealTimeBattle.dvi RealTimeBattle.info RealTimeBattle.txt \
-< note-files note-files-html
----
-> RealTimeBattle.html RealTimeBattle.dvi RealTimeBattle.info \
-> note-files
-292c292
-< RealTimeBattle.html note-files-html
----
-> RealTimeBattle.html
-295,296d294
-<
-< note-files-html: BUGS.html FAQ.html ChangeLog.html TODO.html CVS-Help.html
diff --git a/games/rtb/files/patch-ac b/games/rtb/files/patch-ac
deleted file mode 100644
index 6560cbf8b7e4..000000000000
--- a/games/rtb/files/patch-ac
+++ /dev/null
@@ -1,16 +0,0 @@
---- Documentation/Makefile.am.orig
-+++ Documentation/Makefile.am
-
-41,42c41,42
-< RealTimeBattle.html RealTimeBattle.dvi RealTimeBattle.info RealTimeBattle.txt \
-< note-files note-files-html
----
-> RealTimeBattle.html RealTimeBattle.dvi RealTimeBattle.info \
-> note-files
-46c46
-< RealTimeBattle.html note-files-html
----
-> RealTimeBattle.html
-49,50d48
-<
-< note-files-html: BUGS.html FAQ.html ChangeLog.html TODO.html CVS-Help.html
diff --git a/games/rtb/files/patch-include::fdstream.h b/games/rtb/files/patch-include::fdstream.h
new file mode 100644
index 000000000000..bbcf4906a665
--- /dev/null
+++ b/games/rtb/files/patch-include::fdstream.h
@@ -0,0 +1,18 @@
+--- include/fdstream.h.orig Thu Sep 18 02:35:57 2003
++++ include/fdstream.h Sat Mar 13 02:07:54 2004
+@@ -28,9 +28,15 @@
+ #ifndef BOOST_FDSTREAM_HPP
+ #define BOOST_FDSTREAM_HPP
+
++#if defined __GNUC__ && __GNUC__ < 3
++#include <istream.h>
++#include <ostream.h>
++#include <streambuf.h>
++#else
+ #include <istream>
+ #include <ostream>
+ #include <streambuf>
++#endif
+ // for EOF:
+ #include <cstdio>
+ // for memmove():
diff --git a/games/rtb/files/patch-po::Makefile.in.in b/games/rtb/files/patch-po::Makefile.in.in
new file mode 100644
index 000000000000..e927d41c9a7c
--- /dev/null
+++ b/games/rtb/files/patch-po::Makefile.in.in
@@ -0,0 +1,11 @@
+--- po/Makefile.in.in.orig Sat Apr 26 00:02:45 2003
++++ po/Makefile.in.in Sun Mar 14 10:29:29 2004
+@@ -29,7 +29,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
++mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
+
+ CC = @CC@
+ GMSGFMT = @GMSGFMT@
diff --git a/games/rtb/files/patch-src::Makefile.in b/games/rtb/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..8d9d72c2c7e5
--- /dev/null
+++ b/games/rtb/files/patch-src::Makefile.in
@@ -0,0 +1,15 @@
+--- src/Makefile.in.orig Sun Nov 23 03:44:31 2003
++++ src/Makefile.in Sat Mar 13 02:46:55 2004
+@@ -123,10 +123,10 @@
+ INCLUDES = $(GTK_CFLAGS) -I../include
+
+
+-realtimebattle_CFLAGS = -Wall -O2
++realtimebattle_CFLAGS = -Wall
+
+
+-realtimebattle_CXXFLAGS = -Wall -O2
++realtimebattle_CXXFLAGS = -Wall
+
+
+ bin_PROGRAMS = realtimebattle
diff --git a/games/rtb/files/patch-src::String.cc b/games/rtb/files/patch-src::String.cc
new file mode 100644
index 000000000000..436f856667f3
--- /dev/null
+++ b/games/rtb/files/patch-src::String.cc
@@ -0,0 +1,10 @@
+--- src/String.cc.orig Thu Sep 18 02:51:37 2003
++++ src/String.cc Sat Mar 13 02:12:19 2004
+@@ -25,6 +25,7 @@
+ #include <iostream>
+ //#include <strstream>
+ #include <iomanip>
++#include <stdio.h>
+ #include <stdlib.h>
+ #include <ctype.h>
+