aboutsummaryrefslogtreecommitdiffstats
path: root/games/scorched3d/Makefile
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-11-10 06:33:21 +0800
committerfjoe <fjoe@FreeBSD.org>2003-11-10 06:33:21 +0800
commitb0c186a8b631e84ffc03aa7b442802977d23d498 (patch)
tree1f2022de09b4b655db7f2dea76ecaff6b320e229 /games/scorched3d/Makefile
parent5d653e53be45dc6783eee4ff9c2a49412cb206eb (diff)
downloadfreebsd-ports-gnome-b0c186a8b631e84ffc03aa7b442802977d23d498.tar.gz
freebsd-ports-gnome-b0c186a8b631e84ffc03aa7b442802977d23d498.tar.zst
freebsd-ports-gnome-b0c186a8b631e84ffc03aa7b442802977d23d498.zip
Switch to wxgtk2.
Approved by: mdodd (MAINTAINER)
Diffstat (limited to 'games/scorched3d/Makefile')
-rw-r--r--games/scorched3d/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index ce9de115b21f..fc1c9e134030 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -19,19 +19,19 @@ COMMENT= Scorched is a game based loosely on the classic DOS game
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
SDL_net.0:${PORTSDIR}/net/sdl_net \
- wx_gtk-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk
+ wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
SCORCH_VERSION= 35
WRKSRC= ${WRKDIR}/scorched
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
GNU_CONFIGURE= yes
-USE_MESA= yes
+USE_GL= yes
USE_GMAKE= yes
USE_AUTOMAKE_VER= 15
USE_AUTOCONF_VER= 253
AUTOMAKE_ARGS= --foreign
-CONFIGURE_ARGS= --with-wx-config=${X11BASE}/bin/wx-config
+CONFIGURE_ARGS= --with-wx-config=${X11BASE}/bin/wxgtk2-2.4-config
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
SDL_CONFIG="${LOCALBASE}/bin/sdl11-config"
MAKE_ENV= SDL_CONFIG="${LOCALBASE}/bin/sdl11-config"