aboutsummaryrefslogtreecommitdiffstats
path: root/games/sfbol/Makefile
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-07-16 13:23:44 +0800
committeritetcu <itetcu@FreeBSD.org>2006-07-16 13:23:44 +0800
commitedbd596d92674f9d6738263112ba16c2b20e0a4d (patch)
treefe459ed450ea402b4f401c4ea2d3135930076336 /games/sfbol/Makefile
parent2c321744dc15df73aacbd41f13777360a0e53cbd (diff)
downloadfreebsd-ports-gnome-edbd596d92674f9d6738263112ba16c2b20e0a4d.tar.gz
freebsd-ports-gnome-edbd596d92674f9d6738263112ba16c2b20e0a4d.tar.zst
freebsd-ports-gnome-edbd596d92674f9d6738263112ba16c2b20e0a4d.zip
Update to 4.24 and unbreak
PR: ports/100359 Submitted by: maintainer
Diffstat (limited to 'games/sfbol/Makefile')
-rw-r--r--games/sfbol/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/games/sfbol/Makefile b/games/sfbol/Makefile
index 6fa216021175..8168e6413b52 100644
--- a/games/sfbol/Makefile
+++ b/games/sfbol/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= sfbol
-PORTVERSION= 4.18
+PORTVERSION= 4.24
CATEGORIES= games java
MASTER_SITES= http://www.sfbonline.com/install4/InstData/Java/
DISTNAME= install40
@@ -15,8 +15,6 @@ EXTRACT_ONLY=
MAINTAINER= peter.thoenen@yahoo.com
COMMENT= Star Fleet Battles Online
-BROKEN= fails to install
-
IGNOREFILES= install40.jar
USE_JAVA= yes
JAVA_VERSION= 1.4+
@@ -40,9 +38,11 @@ DESKTOP_ENTRIES= "SFBOL" "Star Fleet Battles Online" \
RESTRICTED= Commerical software. Licenses does not allow redistribution.
+FUDGE= Users/paulfranz/sfbonline/SFBOL-Install/dist/core.jar
+
post-extract:
- @cd ${WRKDIR} && ${JAR} -xf ${DISTDIR}/${DISTFILES} D_/SFBOL/dist/core.jar 2>/dev/null | ${TRUE}
- @cd ${WRKDIR} && ${JAR} -xf D_/SFBOL/dist/core.jar sfbicon.ico
+ @cd ${WRKDIR} && ${JAR} -xf ${DISTDIR}/${DISTFILES} ${FUDGE} 2>/dev/null | ${TRUE}
+ @cd ${WRKDIR} && ${JAR} -xf ${FUDGE} sfbicon.ico
do-install:
@${MKDIR} ${DATADIR}