aboutsummaryrefslogtreecommitdiffstats
path: root/games/shaaft/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-06-15 17:34:11 +0800
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-06-15 17:34:11 +0800
commit35a436665389af6467c6a11408e205d03b73e8b1 (patch)
treef8f0dd2ec9d9ac4b33751b9f16f56068dd17322b /games/shaaft/Makefile
parent8dedcbd056166cb1365cb8794c6e0e826cc8b085 (diff)
downloadfreebsd-ports-gnome-35a436665389af6467c6a11408e205d03b73e8b1.tar.gz
freebsd-ports-gnome-35a436665389af6467c6a11408e205d03b73e8b1.tar.zst
freebsd-ports-gnome-35a436665389af6467c6a11408e205d03b73e8b1.zip
- Fix the build with recent GCC [1]
- Kill teeny pkg-plist, utilize PLIST_FOOs instead - Pacify portlint(1) (unquote BROKEN statement) - Cleanup Makefile (whitespace issues, header) Reported by: pointyhat [1]
Diffstat (limited to 'games/shaaft/Makefile')
-rw-r--r--games/shaaft/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/games/shaaft/Makefile b/games/shaaft/Makefile
index 783b03c2c0eb..14bb74b9b109 100644
--- a/games/shaaft/Makefile
+++ b/games/shaaft/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: shaaft
-# Date created: 02 Jan 2004
-# Whom: krion@FreeBSD.org
+# New ports collection makefile for: Shaaft
+# Date created: 02 Jan 2004
+# Whom: Kirill Ponomarew <krion@FreeBSD.org>
#
# $FreeBSD$
#
@@ -25,22 +25,27 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-optimize
+DATADIR= ${PREFIX}/share/Shaaft
+
+PLIST_FILES= bin/Packer bin/shaaft %%DATADIR%%/resource.dat
+PLIST_DIRS= %%DATADIR%%
MAN6= ${PORTNAME}.6
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
+BROKEN= Does not compile on sparc64
.endif
post-patch:
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG:T}|g ; \
- s|^CXXFLAGS|#CXXFLAGS|g ; \
- s|/usr/X11R6|${X11BASE}|g ; \
- s|-lSDL | |g ; \
- s|-lpng12|-lpng|g' ${WRKSRC}/configure
+ s|^CXXFLAGS|#CXXFLAGS|g ; \
+ s|/usr/X11R6|${X11BASE}|g ; \
+ s|-lSDL | |g ; \
+ s|-lpng12|-lpng|g' ${WRKSRC}/configure
@${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|SDL/SDL|SDL|g'
+ @${REINPLACE_CMD} -e 's|== 3|>= 3|' ${WRKSRC}/utils/hashMap.hpp
.include <bsd.port.post.mk>