aboutsummaryrefslogtreecommitdiffstats
path: root/games/stonesoup
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-03-22 07:05:19 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-03-22 07:05:19 +0800
commita5da770e67afce95b829c38c5d5330fe69f7822c (patch)
treeb9556c9042a9d20d7c71f49869f39f95afc00052 /games/stonesoup
parent51da733b698e7bbedaac4743f457352334401249 (diff)
downloadfreebsd-ports-gnome-a5da770e67afce95b829c38c5d5330fe69f7822c.tar.gz
freebsd-ports-gnome-a5da770e67afce95b829c38c5d5330fe69f7822c.tar.zst
freebsd-ports-gnome-a5da770e67afce95b829c38c5d5330fe69f7822c.zip
Make fonts repecting XDG
Xorg is now looking in ${LOCALBASE}/share/fonts by default Xorg now accepts symlinks in etc/X11/fontpath.d (as decribed in Xserver(1)) Large cleanup on lots of font ports All fonts are now properly dynamically generating fonts.dir and fonts.scale instead of sometime overwriting existing ones) All fonts are generating fontconfig's cache Improve consistency in fonts ports
Diffstat (limited to 'games/stonesoup')
-rw-r--r--games/stonesoup/Makefile4
-rw-r--r--games/stonesoup/files/patch-Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index fb2251d7a092..c356e2c78903 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -58,8 +58,8 @@ MAKE_ARGS+= TILES=y
PLIST_SUB+= SDL=""
PKGNAMESUFFIX= -sdl
BUILD_DEPENDS+= fc-list:${PORTSDIR}/x11-fonts/fontconfig \
- ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
-RUN_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
+ ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
+RUN_DEPENDS+= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2
USE_SDL= sdl image
diff --git a/games/stonesoup/files/patch-Makefile b/games/stonesoup/files/patch-Makefile
index 30a8a7800833..de953b0b10d1 100644
--- a/games/stonesoup/files/patch-Makefile
+++ b/games/stonesoup/files/patch-Makefile
@@ -78,7 +78,7 @@
endif
else
- SYS_PROPORTIONAL_FONT = $(shell dir=/usr/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_PROPORTIONAL_FONT)|head -n 1)
-+ SYS_PROPORTIONAL_FONT = $(shell dir=%%LOCALBASE%%/lib/X11/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_PROPORTIONAL_FONT)|head -n 1)
++ SYS_PROPORTIONAL_FONT = $(shell dir=%%LOCALBASE%%/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_PROPORTIONAL_FONT)|head -n 1)
ifeq (,$(SYS_PROPORTIONAL_FONT))
SYS_PROPORTIONAL_FONT = $(shell dir=/usr/local/share/fonts ; [ -d $$dir ] && find $$dir -iname $(OUR_PROPORTIONAL_FONT)|head -n 1)
endif
@@ -87,7 +87,7 @@
endif
else
- SYS_MONOSPACED_FONT = $(shell dir=/usr/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_MONOSPACED_FONT)|head -n 1)
-+ SYS_MONOSPACED_FONT = $(shell dir=%%LOCALBASE%%/lib/X11/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_MONOSPACED_FONT)|head -n 1)
++ SYS_MONOSPACED_FONT = $(shell dir=%%LOCALBASE%%/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_MONOSPACED_FONT)|head -n 1)
ifeq (,$(SYS_MONOSPACED_FONT))
SYS_MONOSPACED_FONT = $(shell dir=/usr/local/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_MONOSPACED_FONT)|head -n 1)
endif