aboutsummaryrefslogtreecommitdiffstats
path: root/games/sudsol
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-05 07:01:38 +0800
committerpav <pav@FreeBSD.org>2005-09-05 07:01:38 +0800
commit015778ef138653a9b6c58e1935fa23878d2e5c49 (patch)
tree687699240bd1c9ce52a9172a7cc5ab048dd1396a /games/sudsol
parent328e4e59a657a94386e9864bbf23955ac0c28922 (diff)
downloadfreebsd-ports-gnome-015778ef138653a9b6c58e1935fa23878d2e5c49.tar.gz
freebsd-ports-gnome-015778ef138653a9b6c58e1935fa23878d2e5c49.tar.zst
freebsd-ports-gnome-015778ef138653a9b6c58e1935fa23878d2e5c49.zip
Sudsol is a small Sudoku puzzle solver (see
http://en.wikipedia.org/wiki/Sudoku). I've built a small port for it. Have fun! PR: ports/85293 Submitted by: Ed Schouten <ed@fxq.nl>
Diffstat (limited to 'games/sudsol')
-rw-r--r--games/sudsol/Makefile25
-rw-r--r--games/sudsol/distinfo2
-rw-r--r--games/sudsol/pkg-descr18
3 files changed, 45 insertions, 0 deletions
diff --git a/games/sudsol/Makefile b/games/sudsol/Makefile
new file mode 100644
index 000000000000..171a3717fa92
--- /dev/null
+++ b/games/sudsol/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: sudsol
+# Date created: 25 Aug 2005
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sudsol
+PORTVERSION= 0.1
+CATEGORIES= games
+MASTER_SITES= http://rink.nu/downloads/projects/
+
+MAINTAINER= ed@fxq.nl
+COMMENT= A utility to solve Sudoku puzzles
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/sudsol
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' ${WRKSRC}/src/sudsol.c
+
+.include <bsd.port.mk>
diff --git a/games/sudsol/distinfo b/games/sudsol/distinfo
new file mode 100644
index 000000000000..97bbd0f9e10e
--- /dev/null
+++ b/games/sudsol/distinfo
@@ -0,0 +1,2 @@
+MD5 (sudsol-0.1.tar.gz) = 895774d1921e55c2f18d0d86e5f78a25
+SIZE (sudsol-0.1.tar.gz) = 75416
diff --git a/games/sudsol/pkg-descr b/games/sudsol/pkg-descr
new file mode 100644
index 000000000000..abdce64a9537
--- /dev/null
+++ b/games/sudsol/pkg-descr
@@ -0,0 +1,18 @@
+Sudsol is a small utility to solve Sudoku puzzles.
+
+The usage is very simple; add your puzzle to a textfile in the following
+format:
+
+7.94...18
+.3......2
+....974..
+...13.5..
+.....83..
+.4..7...9
+5683...7.
+2.3....51
+.7..2....
+
+and run 'sudsol puzzle.txt'
+
+WWW: http://rink.nu/