aboutsummaryrefslogtreecommitdiffstats
path: root/games/sxsame/Makefile
diff options
context:
space:
mode:
authorflathill <flathill@FreeBSD.org>1999-12-11 03:30:05 +0800
committerflathill <flathill@FreeBSD.org>1999-12-11 03:30:05 +0800
commit57fc7fdd31557a90ae4572032f55d545ec7baa1c (patch)
treeabb2ffb03f55a5de5ecf73180295ffe662c87b0f /games/sxsame/Makefile
parent9199407741e573c2dc6dd87987fea5ee461e3b08 (diff)
downloadfreebsd-ports-gnome-57fc7fdd31557a90ae4572032f55d545ec7baa1c.tar.gz
freebsd-ports-gnome-57fc7fdd31557a90ae4572032f55d545ec7baa1c.tar.zst
freebsd-ports-gnome-57fc7fdd31557a90ae4572032f55d545ec7baa1c.zip
Submitted by: aconitum@po.teleway.ne.jp
A tile-removing puzzle game for the X Window system
Diffstat (limited to 'games/sxsame/Makefile')
-rw-r--r--games/sxsame/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/games/sxsame/Makefile b/games/sxsame/Makefile
new file mode 100644
index 000000000000..a1065ef76ad7
--- /dev/null
+++ b/games/sxsame/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: sxsame
+# Version required: 3.02
+# Date created: 11 December 1999
+# Whom: Yuichi Narahara
+#
+# $FreeBSD$
+#
+
+DISTNAME= sxsame-3.02
+CATEGORIES= games
+MASTER_SITES= ftp://stardust.sfc.wide.ad.jp/pub/JG/JG-0.9.1/sources/\
+ ftp://jg.cc.hit-u.ac.jp/pub/JG/JG-0.9.1/sources/\
+ ftp://ftp.jaist.ac.jp/pub/os/linux/JG/JG-0.9.1/sources/\
+ ftp://mirror.nucba.ac.jp/mirror/JG/JG-0.9.1/sources/
+
+MAINTAINER= aconitum@po.teleway.ne.jp
+
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+
+USE_IMAKE= yes
+NO_INSTALL_MANPAGES= yes
+INSTALL_TARGET= install install.dir
+BINOWN= games
+BINGRP= games
+BINMODE= 2755
+MAKE_ENV+= BINOWN=${BINOWN} BINGRP=${BINGRP} BINMODE=${BINMODE}
+
+WRKSRC= ${WRKDIR}/sxsame-3.02
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/doc/sxsame
+.for i in INSTALL.jp README.jp
+ @${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/doc/sxsame
+.endfor
+
+.include <bsd.port.mk>