aboutsummaryrefslogtreecommitdiffstats
path: root/games/tank/Makefile
diff options
context:
space:
mode:
authorjkh <jkh@FreeBSD.org>1998-03-14 19:41:26 +0800
committerjkh <jkh@FreeBSD.org>1998-03-14 19:41:26 +0800
commitcf0778ec327f184a6978abf21b0e9a89dc4d3c76 (patch)
tree29b52c0ca832444662cf91305123c4652ac21173 /games/tank/Makefile
parentb9879e009f6c98ce1cfab0fec1fdf4d3aa104640 (diff)
downloadfreebsd-ports-gnome-cf0778ec327f184a6978abf21b0e9a89dc4d3c76.tar.gz
freebsd-ports-gnome-cf0778ec327f184a6978abf21b0e9a89dc4d3c76.tar.zst
freebsd-ports-gnome-cf0778ec327f184a6978abf21b0e9a89dc4d3c76.zip
NEW PORT: games/tank, a network tank battle game for Mesa/GL
Note: I suffered a temporary brain glitch on the import and called the vendor tag "XTANK" rather than "TANK". I'm suspecting that's not a total catastrophe, but just to note the inconsistency here in the initial import message. PR: 5916 Submitted by: Donald Burr <dburr@POBoxes.com>
Diffstat (limited to 'games/tank/Makefile')
-rw-r--r--games/tank/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/games/tank/Makefile b/games/tank/Makefile
new file mode 100644
index 000000000000..528063573fdc
--- /dev/null
+++ b/games/tank/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: tank
+# Version required: 0.4a
+# Date created: 4 Mar 1998
+# Whom: Donald Burr <dburr@POBoxes.com>
+#
+# $Id$
+#
+
+DISTNAME= tank-0.4a-src
+PKGNAME= tank-0.4a
+CATEGORIES= games
+MASTER_SITES= http://www.info.polymtl.ca/~coyote/tank/
+
+MAINTAINER= dburr@POBoxes.com
+
+LIB_DEPENDS= MesaGL\\.13\\.:${PORTSDIR}/graphics/Mesa
+
+WRKSRC= ${WRKDIR}/${PKGNAME}
+
+USE_GMAKE= YES
+ALL_TARGET= linux-mesa-elf
+
+# MAN6= xmame.6
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tank ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/lib/tank
+ ${INSTALL_DATA} ${WRKSRC}/*.tga ${PREFIX}/lib/tank
+ ${INSTALL_DATA} ${WRKSRC}/*.au ${PREFIX}/lib/tank
+
+.include <bsd.port.mk>