aboutsummaryrefslogtreecommitdiffstats
path: root/games/tank
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2004-12-05 03:18:43 +0800
committerjeh <jeh@FreeBSD.org>2004-12-05 03:18:43 +0800
commitbb85d43571a89923679031ae99cd3f6072831f26 (patch)
treedff800a0660dd3c39947653f1bb0d17115635e86 /games/tank
parentb5a06b4016093aa3faa246756893c62bfe193a88 (diff)
downloadfreebsd-ports-gnome-bb85d43571a89923679031ae99cd3f6072831f26.tar.gz
freebsd-ports-gnome-bb85d43571a89923679031ae99cd3f6072831f26.tar.zst
freebsd-ports-gnome-bb85d43571a89923679031ae99cd3f6072831f26.zip
Allows games/tank to compile on fbsd 5/6
PR: 74681 Submitted by: MAINTAINER
Diffstat (limited to 'games/tank')
-rw-r--r--games/tank/Makefile4
-rw-r--r--games/tank/files/patch-Makefile.Linux.Mesa8
2 files changed, 4 insertions, 8 deletions
diff --git a/games/tank/Makefile b/games/tank/Makefile
index d3c7ed51b1f6..a5d49ccafdb8 100644
--- a/games/tank/Makefile
+++ b/games/tank/Makefile
@@ -24,10 +24,6 @@ ALL_TARGET= linux-mesa-elf
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tank ${PREFIX}/bin
${MKDIR} ${DATADIR}
diff --git a/games/tank/files/patch-Makefile.Linux.Mesa b/games/tank/files/patch-Makefile.Linux.Mesa
index 44c9dd40cfe1..92cd5a521a83 100644
--- a/games/tank/files/patch-Makefile.Linux.Mesa
+++ b/games/tank/files/patch-Makefile.Linux.Mesa
@@ -1,11 +1,11 @@
---- Makefile.Linux.Mesa.orig Sun Feb 2 18:59:42 1997
-+++ Makefile.Linux.Mesa Sun Nov 16 19:16:50 2003
+--- Makefile.Linux.Mesa.orig Sun Feb 2 12:59:42 1997
++++ Makefile.Linux.Mesa Sat Dec 4 08:56:39 2004
@@ -3,23 +3,23 @@
.SUFFIXES: .cc .o
-ARCH = -DLINUX -DMESA #-DSOUND
-+ARCH = -DLINUX -DPREFIX=\"$(PREFIX)\" #-DUSING_MESA -DSOUND
++TARCH = -DLINUX -DPREFIX=\"$(PREFIX)\" #-DUSING_MESA -DSOUND
MESA = Mesa
@@ -14,7 +14,7 @@
-CFLAGS = $(INCLUDE) $(ARCH) -O2 -m486 -Wall -pipe \
- -pedantic -funroll-loops -mieee-fp
-+CFLAGS += $(INCLUDE) $(ARCH) -DSOUND -Wall -pipe ${PTHREAD_CFLAGS} \
++CFLAGS += $(INCLUDE) $(TARCH) -DSOUND -Wall -pipe ${PTHREAD_CFLAGS} \
+ -pedantic -funroll-loops
-LDFLAGS = -L/usr/X11R6/lib -L$(MESA)/lib